ldap crash in wait4msg

RESOLVED WORKSFORME

Status

MailNews Core
LDAP Integration
--
critical
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, regression, regressionwindow-wanted})

x86
Windows NT
crash, regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB??], crash signature)

(Reporter)

Description

3 years ago
#30 crash for TB31.1.1
appears to be new in version 31.0.

This bug was filed from the Socorro interface and is 
report bp-dd40ae72-c6b7-4fee-85ce-9e0692140910.
=============================================================
 0 	NSLDAP32V60.dll	wait4msg	c-sdk/ldap/libraries/libldap/result.c
1 	NSLDAP32V60.dll	nsldapi_result_nolock	c-sdk/ldap/libraries/libldap/result.c
2 	NSLDAP32V60.dll	ldap_result	c-sdk/ldap/libraries/libldap/result.c
3 	xul.dll	nsLDAPConnectionRunnable::Run()	ldap/xpcom/src/nsLDAPConnection.cpp 

bugzilla@0 444	* For connections that are in the CONNECTING
bugzilla@0 445	* state, check for write ready (which
bugzilla@0 446	* indicates that the connection completed) and
bugzilla@0 447	* transition to the CONNECTED state.
bugzilla@0 448	*/
bugzilla@0 449	if ( lc->lconn_status == LDAP_CONNST_CONNECTING
bugzilla@0 450     && nsldapi_iostatus_is_write_ready( ld,
bugzilla@0 451	   lc->lconn_sb ) ) { 


it seems to be only a few people, eg cgonzalezl crashes frequently bp-9384ef49-5607-4f90-9e23-d155c2140903
(Reporter)

Comment 1

3 years ago
in TB31.2.0 it's only ranked #48.

(In reply to Wayne Mery (:wsmwk) from comment #0)
> #30 crash for TB31.1.1
> appears to be new in version 31.0.
> 
> This bug was filed from the Socorro interface and is 
> report bp-dd40ae72-c6b7-4fee-85ce-9e0692140910.
> =============================================================
>  0 	NSLDAP32V60.dll	wait4msg	c-sdk/ldap/libraries/libldap/result.c
> 1 	NSLDAP32V60.dll	nsldapi_result_nolock
> c-sdk/ldap/libraries/libldap/result.c
> 2 	NSLDAP32V60.dll	ldap_result	c-sdk/ldap/libraries/libldap/result.c
> 3 	xul.dll	nsLDAPConnectionRunnable::Run()
> ldap/xpcom/src/nsLDAPConnection.cpp 
> 
> bugzilla@0 444	* For connections that are in the CONNECTING
> bugzilla@0 445	* state, check for write ready (which
> bugzilla@0 446	* indicates that the connection completed) and
> bugzilla@0 447	* transition to the CONNECTED state.
> bugzilla@0 448	*/
> bugzilla@0 449	if ( lc->lconn_status == LDAP_CONNST_CONNECTING
> bugzilla@0 450     && nsldapi_iostatus_is_write_ready( ld,
> bugzilla@0 451	   lc->lconn_sb ) ) { 
> 
> 
> it seems to be only a few people, eg cgonzalezl crashes frequently
> bp-9384ef49-5607-4f90-9e23-d155c2140903

He also crashes with  nsAbQueryLDAPMessageListener::OnLDAPMessageSearchResult(nsILDAPMessage*) 
https://crash-stats.mozilla.com/report/index/9384ef49-5607-4f90-9e23-d155c2140903
 0 	xul.dll	nsAbQueryLDAPMessageListener::OnLDAPMessageSearchResult(nsILDAPMessage*)	mailnews/addrbook/src/nsAbLDAPDirectoryQuery.cpp
1 	xul.dll	nsAbQueryLDAPMessageListener::OnLDAPMessage(nsILDAPMessage*)	mailnews/addrbook/src/nsAbLDAPDirectoryQuery.cpp 

http://hg.mozilla.org/releases/comm-esr31/annotate/499ed5864793/mailnews/addrbook/src/nsAbLDAPDirectoryQuery.cpp#l175

hg@0   157  if (!cancelOperation)
hg@0   158  {
hg@0   159    switch (messageType)
hg@0   160    {hg@0   173    case nsILDAPMessage::RES_SEARCH_RESULT:
...
hg@0   173    case nsILDAPMessage::RES_SEARCH_RESULT:
bugzilla@10318   174      mWaitingForPrevQueryToFinish = false;
hg@0   175      rv = OnLDAPMessageSearchResult(aMessage);

http://hg.mozilla.org/releases/comm-esr31/annotate/499ed5864793/mailnews/addrbook/src/nsAbLDAPDirectoryQuery.cpp#l289
hg@0   278nsresult nsAbQueryLDAPMessageListener::OnLDAPMessageSearchResult(nsILDAPMessage *aMessage)
hg@0   279{
ehsan@13324   280  int32_t errorCode;
hg@0   281  nsresult rv = aMessage->GetErrorCode(&errorCode);
hg@0   282  NS_ENSURE_SUCCESS(rv, rv);
hg@0   283    
hg@0   284  if (errorCode == nsILDAPErrors::SUCCESS || errorCode == nsILDAPErrors::SIZELIMIT_EXCEEDED)
hg@0   285    return mResultListener->OnQueryResult(
hg@0   286      nsIAbDirectoryQueryResultListener::queryResultComplete, 0);
hg@0   287
hg@0   288  return mResultListener->OnQueryResult(
hg@0   289      nsIAbDirectoryQueryResultListener::queryResultError, errorCode);
Version: 12 → 31
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
(Reporter)

Comment 3

a year ago
This signature doesn't exist after version 31.7.0
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.