IRCTC :- fill up all the details in Seat Availability then navigate to next page, then again back to the previous page the date field changed.

RESOLVED WONTFIX

Status

()

Firefox
General
P1
minor
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Manoj Kumar Sahu, Unassigned)

Tracking

({access})

32 Branch
x86
Windows 8
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

221.65 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
(Reporter)

Description

3 years ago
Created attachment 8492722 [details]
Screenshots of BUG in IRCTC.docx

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

1. Open firefox web browser
2. Give the URL " http://www.indianrail.gov.in/seat_Avail.html " on http tab then press enter
3. Then click on " Seat Availability "
4. Fill all the text boxes including Date field(Date should be greater than current date) & Drop down boxes
5. Click on " Get Availability " button
6. It will navigate to next page.
7. Check all details regarding train then click on " back " button on Mozilla firefox 
8. The page will navigate to " http://www.indianrail.gov.in/seat_Avail.html "



Actual results:

The page whereas all details remaining same as i filled it up, except date field. It shows current date, not the date which i have been selected while i was filling the form.


Expected results:

Date shouldn't be change to current date due to User friendliness of the Website .
(Reporter)

Comment 1

3 years ago
This bug is under Usability Testing to check the user friendliness of the application
Severity: normal → minor
Component: Untriaged → Bookmarks & History
Priority: -- → P1
(Reporter)

Updated

3 years ago
Component: Bookmarks & History → Private Browsing
Keywords: helpwanted
Whiteboard: Verify the date field
(Reporter)

Updated

3 years ago
QA Whiteboard: validate the date field
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.0M?
Iteration: --- → 34.1
Points: --- → 5

Comment 2

3 years ago
Please read https://developer.mozilla.org/en/Bug_writing_guidelines on how to file a bug, do not set the security flag unnecessarily and do not attach word documents to show screen shots. They can potentially contain malicious scripts and no one will load them.

The month and day are in the inputs lccp_month and lccp_day in seat_Avail.html lines 794, 798. They are unconditionally set via the function showdate() in set_Avail.html line 461 when the seat_Avail,html page is loaded.

When you click Get Availability, a post if performed. When you click back, the page is reloaded via a GET and the values in document.acc_avl.lccp_month.value, document.acc_avl.lccp_day.value retain their values set previously until the showdate() function is called which resets them.

Note that Chrome 37 does not reset the dates and I presume does not re-GET the page or re-run the global scripts on the page on navigating back.

Note I tested with Nightly and Chrome on Linux.

Leaving open since I can't recall the exact rules for POST and navigating back through history. 

bz?
Group: core-security
blocking-b2g: 2.0M? → ---
Iteration: 34.1 → ---
Points: 5 → ---
QA Whiteboard: validate the date field
Component: Private Browsing → General
Keywords: helpwanted
Whiteboard: Verify the date field
The short of it is that if this page is loaded from bfcache it will keep the value you set, and if it's reloaded via a fetch it will rerun the scripts which will call showdate().  There's no way to get around that, unfortunately.

And this particular page cannot be saved in bfcache because it has unload listeners.  Note that the unload listener does nothing; the page is explicitly using it to produce this behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

3 years ago
Hi  Bob Clary,
     If the date field getting reset, so that all field should get reset. This is a path bug, which is not given properly. So as per the condition of customer this should not be happen like this. The website should be user friendly otherwise everything is good.
     Therefore kindly consider my request, i will be highly obliged to you.

Regards
Manoj Kumar Sahu
MOb-8884769688
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(nobody)
Keywords: access
Resolution: WONTFIX → ---
Whiteboard: Verify the date field for customer usability

Comment 5

3 years ago
Manoj, Boris explained that the issue is not with Firefox but with the web page. If you remove the onunload handlers then the page will not be re-requested when navigating back and the values won't change.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(nobody)
Resolution: --- → WONTFIX
Whiteboard: Verify the date field for customer usability
(Reporter)

Comment 6

3 years ago
Dear Bob,
   I am fully appreciate you, but my issue is that this problem occurring in every browser. Thing is that the main bug is in the website itself. So for customer reliability consider this.


Thank you
Flags: needinfo?(nobody)

Comment 7

3 years ago
Manoh, we aren't responsible for the web site's content. If you are responsible, you can fix it or contact the web site's authors.

There are two ways to fix the web site as we've already discussed:

1. don't call showdate() unconditionally when the page loads. only call in response to user input.

2. don't use onunload event handlers.
Flags: needinfo?(nobody)
You need to log in before you can comment on or make changes to this bug.