Phone overheats in pocket due to flash being on in camera

RESOLVED FIXED

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Rika Pi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
On a Flame Reference Phone Firefox OS 2.2(nightly)
This would probably only work on phones with an inbuilt LED flash.
Also have reason to believe it would also happen in lower versions of Firefox OS

Steps to reproduce:
Have flash set to "Auto" or "On" in Camera
Put phone in pocket with camera app on

(Also this can sometimes happen when the camera app triggers while in the pocket)

Due to the flash being on for a long time the phone (and you pocket) can get very hot and could damage the hardware of the phone.
Rika, there have been a number of changes recently with focus and flash control. Can you retest this with a more recent version and let us know whether or not this problem still exists?
Flags: needinfo?(walker.pilot.b)
(Reporter)

Comment 2

3 years ago
It no longer appears to be a problem.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(walker.pilot.b)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.