[ca] Multiple regressions in region.properties (mobile, desktop)

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: flod, Assigned: egamonal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It's already the second time this happens (see bug 1036875).

A ton of changes land, and they include changes to productization files on both Aurora and Central
http://hg.mozilla.org/releases/l10n/mozilla-beta/ca/rev/df77cb55de30

Both mobile and browser region.properties regressed badly.

This time I'm not going to fix it, because I'd like the team to
a) To be aware of this, and that this kind of changes will get your sign-offs rejected.
b) To change the way you work on these files once and for all.

Best way to fix this is to use "hg revert"

hg revert browser/chrome/browser-region/region.properties -r 5024653124c9
hg revert mobile/chrome/region.properties -r 5024653124c9

Note that you've changed region.properties for other products too.
Flags: needinfo?(egamonal)
Hi Francesco,
sorry for the mess. I explicitly ignored all searchplugins files but I clearly didn't  for region.properties
I'm changing it and coming back here.

the reason these changes land all together is that we use a pootle installation. conversion from po to mozilla formats produces errors and it takes a long time to fix them, so we only do it once per cycle. Moreover, the commmunity tends to translate everything the last week, so there aren't real partial changes to commit.
Flags: needinfo?(egamonal)
Any specific reason for not using Pootle directly (http://mozilla.locamotion.org/ca/)? I haven't seen many issues in the last year and a half, and it's also set-up to ignore productization files.

I have the feeling it would also free you from administrative burden.
see changesets 7da0f66c7f3b and 64dd3cb12d2c

http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/7da0f66c7f3b
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ca/rev/64dd3cb12d2c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.