Firefox Mobile doesn't render <setting> with type = "directory"

RESOLVED WONTFIX

Status

()

Firefox for Android
Settings and Preferences
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: Denis, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8493070 [details]
preview without setting

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0
Build ID: 20140410211200

Steps to reproduce:

I have added setting in options.xul file:

<setting type="directory" pref="extensions.fvd_single.download.folder" title="&txt.fennec.download.custom_folder.title;" />


Actual results:

In options page for my addon I see nothing


Expected results:

directory picker or something else should be rendered?
Does fennec define a different syntax for inline options differently? What are other add-ons using?
Flags: needinfo?(mark.finkle)
(Reporter)

Comment 2

4 years ago
I can't find any other fennec addon that allows user to pick directory from device... Maybe fennec doesn't supports "directory" for now, but I can't find any info about it and ask question here, maybe this is a bug.
(In reply to Denis from comment #2)
> I can't find any other fennec addon that allows user to pick directory from
> device... Maybe fennec doesn't supports "directory" for now, but I can't
> find any info about it and ask question here, maybe this is a bug.

Correct. Fennec does not support "directory" inline types. We don't have a way to let people pick a folder, mainly because Android doesn't use that metaphor.

Wes has been thinking about use cases for "folder pickers" in the past, but I don't know that we have a compelling reason to build it out right now.
Flags: needinfo?(mark.finkle)
I'm going to WONTFIX this for now.

For your add-on, why not just add an option to "Save to the SD Card"? Most people have no idea about folders on their phones, and Androids makes it very difficult to try to pick a folder anywhere but the SD Card any way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.