Global rating stars from Reviews section are not displayed correctly after a review is submitted

RESOLVED WONTFIX

Status

Marketplace
Consumer Pages
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Iulian Timis, Unassigned)

Tracking

x86_64
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: [marketplace-transition])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8493112 [details]
rating stars not updated.png

Steps to reproduce:
1. Sign in on MP-Stage app on Inari.
2. Load details page for an app that has not been reviewed yet.
3. Submit a review.

Expected result:
Ratting stars on the "# Review" button are updated according to your submitted review.

Actual result:
Ratting stars on "# Review" button are not displayed correctly after submitting a review. If you sign out and sign in again the ratting stars are displayed correctly.

Notes/Issues:  
Verified on FF OS 1.4 (Inari). Not reproducing on MP-Stage FF35 (Win 7).
Attached screenshot for this issue.
Summary: Ratting stars on Review button are not displayed correctly after a review is submitted → Rating stars on Review button are not displayed correctly after a review is submitted

Updated

3 years ago
Priority: -- → P3
Target Milestone: 2014-09-23 → ---

Updated

3 years ago
Summary: Rating stars on Review button are not displayed correctly after a review is submitted → Global rating stars from Reviews section are not displayed correctly after a review is submitted

Comment 1

3 years ago
The issue from comment #0 is still reproducing even after Desktop UI refresh, following the STR from bellow:

Steps to reproduce:
1. Sign in on MP-dev app on FFOS 1.4 (Inari)
2. Load details page for an app that has not been reviewed yet (i.e. Mock Application 1424109779)
3. Submit a review.

Expected results:
Ratting stars from the "Reviews" section are updated according to your submitted review.

Actual results:
Ratting stars from the Reviews section are not displayed correctly after submitting a review. 

Notes/Issues:  
Verified on FF OS 1.4 (Inari). Issue is also reproducing on MP-stage, MP-dev on FF39 (Win 7). On desktop the stars are correctly displayed after page refresh.
Screencast for this issue: http://screencast.com/t/pvGj2l1hY8

Comment 2

2 years ago
Issue is reproducing on FF OS 2.5 Flame and it is a bit disturbing, because,if you want to see the correct number of global rating stars, you must restart the Marketplace app.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [marketplace-transition]
You need to log in before you can comment on or make changes to this bug.