Site loaded does not correspond to address displayed in address bar using auto-completion.

RESOLVED DUPLICATE of bug 1043584

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1043584
4 years ago
4 years ago

People

(Reporter: epok__, Unassigned)

Tracking

32 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140917194002

Steps to reproduce:

Type some letters in the address bar. The most frequently visited site address appears, as well as a drop-down list. Move your mouse over a site in the list, then click in the address bar. The drop-down list disappears, and the address in the bar hasn't changed. Validate using enter.


Actual results:

Guess which site is loaded? Not the one whose address was displayed in the bar, but the one you highlighted using the mouse... This is not a coherent behavior, and frequently happens to me when I type an address while not releasing mouse and unwillingly move it.


Expected results:

The site whose address is displayed in the address bar should have been loaded.

Comment 1

4 years ago
I'm not able to reproduce the issue, are you sure you don't scroll in the drop-down list with the keyboard arrows?

Updated

4 years ago
Component: Untriaged → Location Bar
(Reporter)

Comment 2

4 years ago
Nop, I just point an entry in the list, then click back in the address bar to make the list disappear. It does that every time I do it, whatever the address is.

Note that I don't type anything in the bar after doing it. I just validate the default entry. It does the same even if I click twice in the bar, setting the selected text (automatically added) unselected.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
You need to log in before you can comment on or make changes to this bug.