Closed Bug 1071064 Opened 6 years ago Closed 6 years ago

[Contacts] [ICE Settings] Even if Select ICE Contact button is disabled it can be clicked

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jmcf, Assigned: crdlc)

Details

Attachments

(1 file)

STR:

If ICE Contact 1 or ICE Contact 2 are unchecked, the Select Contact button is disabled. However, under these conditions, if it is tapped on the button, then the switch is checked as if the button where clickable, when it shouldn't
I have reproduce the problem in a Firefox Simulator 2.2.

This seems due to the "ice-contacts-switch" buttons with a larger clickable space, which covers about half the select-ice-contact buttons, but I did not see this point from the developer tools - inspector.


However, I have an idea, if the switch buttons real full covers the select buttons, maybe it is a good feature to save operating costs of the user, just maybe.
Assignee: jmcf → crdlc
Attached file Github pull request
thanks
Attachment #8493611 - Flags: review?(jmcf)
I left a couple of comments on GH
Comment on attachment 8493611 [details]
Github pull request

good work.

Please land once you get a green TBPL

thanks!
Attachment #8493611 - Flags: review?(jmcf) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/5fd71bdab1201b3456f19aa15da271023ad437a1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Tested and working
2.2
User
Flame
Gecko-27b927d
Gaia-83d7245

Pending 2.1
(In reply to Loli (:lolimartinezcr) from comment #6)
> Tested and working
> 2.2
> User
> Flame
> Gecko-27b927d
> Gaia-83d7245
> 
> Pending 2.1

I don't know if this is going to be uplifted
Comment on attachment 8493611 [details]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: weird behavior
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: No
Attachment #8493611 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8493611 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Loli, please test this is fixed against a 2.1 build.  If yes, then clear the "verifyme" keyword, and switch the flag: status-b2g-2.1 == 'verified'.  Thanks.
Flags: needinfo?(lolimartinezcr)
Keywords: verifyme
Tested and working
Flame
2.2
User
Gecko-f24dab7
Gaia-ec272b4

Tested and not working
Flame
2.1
User
Gecko-a38df34
Gaia-86905e1
Flags: needinfo?(lolimartinezcr)
Issue is verified fixed in Flame 2.2, 2.1 builds (Full Flash, nightly).

Actual Results: The "Select Contact" button in ICE Contacts page behaves correctly. 

Device: Flame Master
Build ID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Version: 36.0a1 (Master)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
BuildID: 20141024001204
Gaia: 0f76e0baac733cca56d0140e954c5f446ebc061f
Gecko: 7d78ff7d25b6
Version: 34.0 (2.1) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.