some alternate stylesheets inaccessible if menu used before load finishes

RESOLVED DUPLICATE of bug 47734

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 47734
17 years ago
17 years ago

People

(Reporter: Anand Kumria, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011023
BuildID:    20011023


the source for the page above contains 10 alternative stylesheets; however only
the first alternative is selectable in the View|Use Stylesheet.

Reproducible: Always
Steps to Reproduce:
1. go to web page
2. attempt to select the 'Modernist' stylesheet


Actual Results:  apart from 'OldStyle' (the first alternative), 'None' (I assume
generated by Mozilla) and 'Default' (first named style) no others are available.

Expected Results:  Presentened with all the other available 'alternative'
stylesheets.

Comment 1

17 years ago
I went to the page (actually, I was redirected), and tried switching between all
the alternate stylesheets and I could use all of them.

Worksforme on build 2001-10-26-03 using Windows 98.

Comment 2

17 years ago
I've seen this problem on 2001101715 as well (i386 Linux Debian unstable).

The problem seems to occur -only- if I open the View->Use Stylesheet menu before
the pag is finished loading. If I do that, then even after the page finishes
loading, I don't see the rest of the alternate stylesheets. There's probably a
race condition involved here, as I have gotten the compelete list of alternates
occasionally even though I opened the menu before the page completed loading.

OTOH, I always get the complete menu if I wait until the page has finished
loading before going to View->Use Stylesheet.
(Assignee)

Updated

17 years ago
Summary: not all alternate stylesheets can be selected → some alternate stylesheets inaccessible if menu used before load finishes
(Reporter)

Comment 3

17 years ago
Okay, just tried that again on 2001101202 and if I wait until the page is
completely loaded I can switch amongst the other stylesheets. Reloading the page
is a work-around.
Duplicate of "DOM StyleSheets collection inaccurate if retrieved during page
load [AltSS]"

*** This bug has been marked as a duplicate of 47734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.