[Messages] Sharing an image via MMS, the User is shown the "Messages" page first before being taken to the "New Message" page

RESOLVED DUPLICATE of bug 1013738

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1013738
3 years ago
3 years ago

People

(Reporter: FredM, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8493317 [details]
logcat_20140922_1159.txt

Description:
When sharing an image via SMS, the "Messages" page appears before the "New Message" is shown


Repro Steps:
1) Update a Flame to 20140922000332
2) Launch Gallery app
3) Tap on any photo
4) Tap on "Share" icon
5) Tap on "messages" button
6) Observe what happens


Actual:
The User is taken to the "Messages" page first before being taken to the "New Message" page


Expected:
The User is taken directly to the "New Message" page

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: video clip, logcat https://www.youtube.com/watch?v=sUv8mepHtDI&edit=vd
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue is reproducible on Flame 2.2 (319mb), 2.2 KitKat (319mb), Flame 2.1 (512mb), Flame 2.1 KitKat (319mb), Flame 2.0 KitKat Base (319mb), Flame 2.0 (319mb), Open_C Master, Open C 2.1 and Open_C 2.0 

Result: The User is taken to the "Messages" page first before being taken to the "New Message" page

Environmental Variables:
Device: Flame 2.2 Master
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.2 KitKat (319mb)
BuildID: 20140922043003
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.1 (512mb)
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140922063004
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 2.0 KitKat (319mb) 
Build ID: 20140922082143
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: dc61f92b855e
Version: 32.0 (2.0)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Open_C 2.2
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Whiteboard: [2.1-exploratory] → [2.1-exploratory-2]
Same root cause than bug 1013738. Not _that_ easy to fix correctly, we need to add more lazy loading first.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013738
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.