Closed Bug 1071225 Opened 6 years ago Closed 6 years ago

[e10s] FxAccountsOAuthClient.jsm can't close the tab with e10s

Categories

(Firefox :: Firefox Accounts, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Iteration:
35.2
Tracking Status
e10s m3+ ---

People

(Reporter: MattN, Assigned: vladikoff)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

While testing with e10s, alexis was not able to login to Loop at https://accounts.firefox.com/oauth/signin 
The problem may be in WebChannel.jsm or FxAccountsOAuthClient.jsm
Flags: firefox-backlog+
Flags: qe-verify?
I see bug 1061013 disabled browser_fxa_oauth.js so that's probably a good starting place.
INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/general/browser_fxa_oauth.js | Found an unexpected tab at the end of test run: http://example.com/browser/browser/base/content/test/general/browser_fxa_oauth.html?action=signin&webChannelId=oauth_client_id&client_id=client_id&scope=&state=state - expected PASS
QE should be able to login to FxA via Loop with E10S once this bug is fixed.
Flags: qe-verify? → qe-verify+
Matt, thanks for filing? Mind fixing it too?
Assignee: nobody → MattN+bmo
Matt, I can take a look at this if you are busy with other stuff / don't have a patch in progress
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #4)
> Matt, thanks for filing? Mind fixing it too?

I was hoping Vlad would volunteer because he's awesome like that :) I haven't started on this yet.
Assignee: MattN+bmo → vlad
Status: NEW → ASSIGNED
The good news - authentication actually works and Loop logs in. The bad news - it cannot close the tab.
OK, updating the summary.
Summary: [e10s] FxA OAuth login doesn't work with e10s → [e10s] WebChannel.jsm can't close the tab with e10s
Summary: [e10s] WebChannel.jsm can't close the tab with e10s → [e10s] FxAccountsOAuthClient.jsm can't close the tab with e10s
Enabling e10s testing for this module.
Attachment #8494174 - Flags: review?(MattN+bmo)
Comment on attachment 8494174 [details] [diff] [review]
0001-Bug-1071225-Fixes-FxA-OAuth-to-work-properly-with-e1.patch

Review of attachment 8494174 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! This looks good to me.

I'll push this later as I've run both kinds of tests locally and did manual testing in E10S and non-E10S mode.
Attachment #8494174 - Flags: review?(MattN+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/1105c83a13bf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla35
Iteration: --- → 35.2
I was able to reproduce the "login" issue from Comment 0 "alexis was not able to login to Loop". I used Nightly 35.0a1 (2014-09-24) on Windows 7 x64 and I accessed the Loop pop-up where I selected the Sign-in link. I was redirected to https://accounts.firefox.com/oauth/signin?webChannelId=oauth_a8b39c2b1cab722e&client_id=a8b39c2b1cab722e&scope=profile&state=156c86df721168ae76d1f7e4ac88b369b34e15a51381e118e71f57f51d225833 page and here is the place where I was unable to login.

The link from Comment 0 https://accounts.firefox.com/oauth/signin is the page where the user logs-in to Firefox Account, which on the other hand works fine. Actually logging to this page does not log the user to Loop.
The Tab issue from Comment 7 "bad news - it cannot close the tab" I was unable to reproduce it, all tabs closing successfully.
Vlad can you please clarify me a little bit since you have reproduced the tab issue? Right now I am not sure which is the bug here.

Vlad, if "close tabs" is really the issue here can you please verify if it is fixed since I was unable to reproduce that part.
Flags: needinfo?(vlad)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #13)
> I was able to reproduce the "login" issue from Comment 0 "alexis was not
> able to login to Loop". I used Nightly 35.0a1 (2014-09-24) on Windows 7 x64
> and I accessed the Loop pop-up where I selected the Sign-in link. I was
> redirected to
> https://accounts.firefox.com/oauth/
> signin?webChannelId=oauth_a8b39c2b1cab722e&client_id=a8b39c2b1cab722e&scope=p
> rofile&state=156c86df721168ae76d1f7e4ac88b369b34e15a51381e118e71f57f51d225833
> page and here is the place where I was unable to login.
> 
> The link from Comment 0 https://accounts.firefox.com/oauth/signin is the
> page where the user logs-in to Firefox Account, which on the other hand
> works fine. Actually logging to this page does not log the user to Loop.
> The Tab issue from Comment 7 "bad news - it cannot close the tab" I was
> unable to reproduce it, all tabs closing successfully.
> Vlad can you please clarify me a little bit since you have reproduced the
> tab issue? Right now I am not sure which is the bug here.
> 
> Vlad, if "close tabs" is really the issue here can you please verify if it
> is fixed since I was unable to reproduce that part.

Sorry this bug is from September and was resolved. I'm really confused why are you testing it in Nightly 35.0a1 (2014-09-24). Let me know.
Flags: needinfo?(vlad)
(In reply to Vlad Filippov from comment #14)

> Sorry this bug is from September and was resolved. I'm really confused why
> are you testing it in Nightly 35.0a1 (2014-09-24). Let me know.

I was trying to reproduce this issue in order to verify it on latest Nightly.

I do not know exactly what should I verify because the summary of this bug was changed and I managed to reproduce only the first version "Summary: [e10s] FxA OAuth login doesn't work with e10s".
I was able to reproduce the issue mentioned in comment 7 using the 2014-09-24 Nightly on Ubuntu 12.04 32-bit.

Confirming the fix on latest Nightly, build ID: 20141230030214 on Ubuntu 12.04 32-bit, Windows 7 64-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Product: Core → Firefox
Target Milestone: mozilla35 → Firefox 35
You need to log in before you can comment on or make changes to this bug.