[Camera] Previewing a picture that is just taken and then rotating the phone will shift the UI and create black space

VERIFIED FIXED in Firefox 34

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: onelson, Assigned: jrmuizel)

Tracking

({regression})

unspecified
mozilla35
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

()

Attachments

(2 attachments)

Description:
When the user takes a photo with the camera and then observes the picture via the in-App gallery, they may be prone to UI faults. Upon rotating the phone to shift from portrait-to-landscape views, the phone will present black space and cut-off UI until the user proceeds to tap the photo or slide to the next photo in queue.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140922043003
2) Open 'Camera' app.
3) Take some photos (can be performed with one).
4) Tap bottom left preview to view all the photos taken this session.
5) While observing the taken photos, rotate the phone 90 degrees (portrait-to-landscape || landscape-to-portrait).
6) Observe screen.
  
Actual:
Preview rotates and produces blackspace/cut-off UI for the remaining view of the photo and surrounding UI elements.
  
Expected: 
Preview photo rotates with phone.
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140922043003
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  

Repro frequency: 5/5 attempts
See attached: 
video- http://youtu.be/6JPJhIrA6iE
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Summary: Summary (title) Field: [Camera] Previewing a picture that is just taken and then rotating the phone will shift the UI and create black space → [Camera] Previewing a picture that is just taken and then rotating the phone will shift the UI and create black space
QAWanted for branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This bug repro's on Flame KK builds: Flame 2.2 KK, OpenC 2.2

Actual Results: Viewing preview images taken in the camera and rotating the camera to landscape mode causes the images to be incorrectly displayed.

Repro Rate: 4/4

Environmental Variables:
Device: Flame Master KK
BuildID: 20140923065343
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9e193395b912
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140922185743
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK, Flame 2.0 KK Base

Actual Result: No issues seen when viewing photos in landscape mode, taken in the camera app. 

Repro Rate: 0/9

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20140922185144
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20140923035745
Gaia: 6449cc35a8f0704d95acac374ba857bde4b86d6c
Gecko: b930730dba81
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK Base
BuildID: 20140904160718
Gaia: 506da297098326c671523707caae6eaba7e718da
Gecko: 
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
Blocking Triage -  Nomming for 2.2 - regression in a major feature, very poor UX along a fairly standard user-path.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Contact: pcheng
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140911071536
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: e7695039b761
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140911081732
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 0ba56b8f5946
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e7695039b761&tochange=0ba56b8f5946

Caused by Bug 1064479 ?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by bug 1064479 - can you take a look Jeff?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(jmuizelaar)
Assignee: nobody → jmuizelaar
Blocks: 1064479
Flags: needinfo?(jmuizelaar)
Component: Gaia::Camera → Graphics: Layers
Product: Firefox OS → Core
It is confusing that this is only an issue for 2.2, and not for 2.1 as well.
blocking-b2g: 2.2? → 2.2+
Bug 1064479 hasn't been uplifted to Aurora yet due to the regressions it caused.
Attachment #8497068 - Flags: review?(matt.woodrow) → review+
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #7)
> Bug 1064479 hasn't been uplifted to Aurora yet due to the regressions it
> caused.

Let's make sure the correct things end up on Aurora.  Since this is blocking a 2.1+ (bug 1064479), it needs to be 2.1+ as well, or we won't be able to uplift that bug.
blocking-b2g: 2.2+ → 2.1+
https://hg.mozilla.org/mozilla-central/rev/514846b70ea1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Please nominate this patch for Aurora approval when you get a chance :)
Comment on attachment 8497068 [details] [diff] [review]
Make sure we call ComputeRotation before calling TransformShadowTree

Approval Request Comment
[Feature/regressing bug #]:1064479
[User impact if declined]: This is necessary for the correct behavior of 2.1 accessibility feature described in bug 1016539.
[Describe test coverage new/current, TBPL]:
[Risks and why]: 
[String/UUID change made/needed]:
Attachment #8497068 - Flags: approval-mozilla-aurora?
Flags: needinfo?(jmuizelaar)
Attachment #8497068 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Note that I can't do anything with this until bug 1064479 and bug 1066664 are also approved for uplift.
Flags: needinfo?(milan)
Just requested aurora approval for bug 1064479 and bug 1066664
Flags: needinfo?(milan)
This bug is verified fixed on the Flame 2.1 (319mb) and the Flame 2.2 (319mb)


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: Preview photo rotates with phone.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1088303
You need to log in before you can comment on or make changes to this bug.