Copy & Paste in X results in two extra newlines

VERIFIED DUPLICATE of bug 98572

Status

--
major
VERIFIED DUPLICATE of bug 98572
18 years ago
13 years ago

People

(Reporter: joshua, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    0.9.5

When I select text in the mozilla window (thus copying it in X), and then paste 
it into a terminal (say eterm), I get the text I selected and two newlines 
(which is always messing me up when I'm trying to paste IP addresses from 
mozilla to the shell for troubleshooting). It happens every time, no matter 
what text I select. I could select a 'P' and I would end up pasting "P\n\n". 
Help!

Reproducible: Always
Steps to Reproduce:
1.Select text
2.Move to terminal
3.Paste

Actual Results:  You get whatever you selected followed by two newlines.

Expected Results:  I expect to get just the characters I selected.
Are you by any chance selecting pre-formatted text?

I can't reproduce this problem in a recent build....

Comment 2

18 years ago
Related: bug 106448 on NT (but that affects editor areas)

On a current linux build I see the mouse x-selection pasting 2 additional
linefeeds in xterm if i copy content from browsers content area.

I do NOT see additional linefeeds pasted if i have select-copied from editor
areas, like this form, or mailcompose.

Comment 3

18 years ago
ahh..the text in a bug report is perceived as pre formatted.. that is bug 98572
If i copy from cnn.com, i don't get extra linefeeds.

Reporter: Does the double linefeed happen everywhere, or is only <pre> formatted
text of <H1> (and simliar) ?
(Reporter)

Comment 4

18 years ago
it happens in preformatted and normal text. It does not happen in form fields. 
(Reporter)

Comment 5

18 years ago
On testing this with another workstation I can only reproduce the error with 
Preformatted text. Sorry for the earlier report of all text.

Comment 6

18 years ago
Thanks for quick followup! 
Resolving as dup of bug 98572

*** This bug has been marked as a duplicate of 98572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.