Port existing tests for ICS to KK

RESOLVED DUPLICATE of bug 1090359

Status

RESOLVED DUPLICATE of bug 1090359
4 years ago
4 years ago

People

(Reporter: jlal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Right now we are running many tests (reftest, mochitest, etc..) on the ICS emulator... We don't care so much about ICS these days and as a first step to removing the ICS tests we should port everything to the KK emulator...

Simply getting the first part running should be easy we can just swap out the emulator binary used in the tests with the KK emulator and see how green/red it is and then start greening it up.
This is Jamin from Bluetooth team.
It would be great for BT team to switch from ICS emulator to KK emulator.

ICS emulator uses BlueZ as Bluetooth protocol stack, however, most of our upcoming products use BlueDroid library with KK-image. The difference between BlueZ and BlueDroid is significant from implementation aspect. I believe it would be much better to run automated tests on KK emulator.

Moreover, BT team is working on exposing a new set of Bluetooth API [1] for privileged apps to use, including classic Bluetooth and Bluetooth low energy.
The new API set only supports BlueDroid as backend and it's going to replace current BT API on B2G 2.2. 
It means ICS emulator will not be compatible with Bluetooth API after B2G 2.2 FL. (since we don't support BlueZ anymore.) 
[1] https://wiki.mozilla.org/B2G/Bluetooth/WebBluetooth-v2

I understand it take time for the transition and it need help from different comments.
Bluetooth team will write new marionette tests for BT API v2 and test them on KK emulator recently.
If there are any Bluetooth issue during the transition, please feel free to open bugs.

Thank you very much.

Updated

4 years ago
Blocks: 1090359

Updated

4 years ago
Blocks: 1124557

Updated

4 years ago
No longer blocks: 1124557
Hi it looks to me that this is a duplicate of bug 1090359. Feel free to reopen it if I misunderstand anything, thank you.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1090359
You need to log in before you can comment on or make changes to this bug.