Closed Bug 1071336 Opened 6 years ago Closed 5 years ago

[Video player] larger .ogv videos have performance issues in video player

Categories

(Core :: Audio/Video: MediaStreamGraph, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1168674
tracking-b2g -
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: rmitchell, Assigned: jhlin)

References

()

Details

(Keywords: perf, regression, Whiteboard: [2.1-exploratory-2])

Attachments

(4 files)

Attached file log cat
Description:
larger videos have performance issues in video player
 including lagging video when tapping on time line.

Setup: Run the X heavy script 

Repro Steps:
1) Update a Flame to 20140922063004
2) Open a video over 2.5 MB the video player 
3) Tap around the time bar 


Actual:
Video is lagged to start up again .


Expected:
Video starts with no lag.

Environmental Variables:
Device: Flame 2.1
Build ID: 20140922063004
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 2.1
Firmware Version: 123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes: Video used for bug was a .ogv

Repro frequency:100%
See attached:logcat,video clip: https://www.youtube.com/watch?v=q_GgTqEwzyY&feature=youtu.be
This issue DOES occur on Flame 2.2 (319mb),Open C 2.2, Flame 2.1(512mb), Open C 2.1, Flame 2.0 KitKat Base (319mb) flame 2.0(319 mb) open C 2.0,


larger videos have performance issues in video player

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame 2.2 
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0



Open C 2.2

Environmental Variables:
Device: Open_C 2.2
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.2 (319mb)

Device: Flame 2.2
BuildID: 20140922043003
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1 
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
Build ID: 20140922063004
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140922082143
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: dc61f92b855e
Version: 32.0 (2.0)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0



Open_C 2.0

Enviromental Variables:
Device: Open_C 2.0
BuildID: 20140917000200
Gaia: 31434a3949556171f3565ca47ac2b44e810e95e6
Gecko: 989a723d7e2e
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory] → [2.1-exploratory-2]
This seems to be a minor bug, the video will pause for a moment and then resume. Not nominating to block
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Keywords: perf
Keywords: qawanted
QA Contact: jthomas
This issue does occur on the Flame 3.0

Video still appear to be lagging when jumping throughout the video. Is there any other information you need for this bug Bobby?

Environmental Variables:
Device: Flame 3.0
Build ID: 20150518010206
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: 35918b0441b4
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(bchien)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Tracking Requested - why for this release]:

John, could you attach your 2.5M test file? thanks.
Flags: needinfo?(bchien) → needinfo?(jthomas)
Attached video TestFile5mb.3gp
Sure thing. Video is attached. The video is not appearing to lag consistently. I would say about 1 out of every 5 jumps within in the video.
Flags: needinfo?(jthomas) → needinfo?(ktucker)
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2][perf-wanted]
I can't reproduce this in v2.2, but v3.0 does reproducible. Noted this case as regression.

Good video: https://www.youtube.com/watch?v=oI3SjvJY0xE
blocking-b2g: --- → 3.0?
Component: Performance → Gaia::Video
Keywords: regression
adding qawanted since we cannot see the youtube video anymore linked in the description.  Can we have a video of the regression behavior?
Keywords: qawanted
Also it would be nice to check whether this is still reproducible.
Flags: needinfo?(rmitchell)
Because I have no .ogv video file, I just used the video in comment 5 to reproduce this Problem.
Problem cannot be reproduced in latest build of Flame 2.0/2.1/2.2 by the STR in comment 0, but it is reproducible in V3.0.
See attachment: Flame3.0_logcat_1228.txt & Flame3.0_issue can be reproduced.mp4
Flame 3.0 rate: 5/5
Flame 2.0 rate:0/10
Flame 2.1 rate:0/10
Flame 2.2 rate:0/10

Device information:
Flame 2.0 (319mb)
Build ID               20150607000203
Gaia Revision          5552bf529d3d6775a968942e9afa6c1d4037362c
Gaia Date              2015-05-21 14:42:19
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/19fbe3aef440
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.035002
Firmware Date          Sun Jun  7 03:50:13 EDT 2015
Bootloader             L1TC000118D0

Flame 2.1 (319mb)
Build ID               20150607001204
Gaia Revision          2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gaia Date              2015-05-26 13:30:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbace93b522
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.035246
Firmware Date          Sun Jun  7 03:52:57 EDT 2015
Bootloader             L1TC000118D0

Flame 2.2 (319mb)
Build ID               20150607002503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d213237e11e9
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.035848
Firmware Date          Sun Jun  7 03:58:59 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (319mb)
Build ID               20150607160204
Gaia Revision          1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gaia Date              2015-06-05 17:55:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7d4ab4a9febd
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150607.193246
Firmware Date          Sun Jun  7 19:32:58 EDT 2015
Bootloader             L1TC000118D0

Leaving qawanted in case someone else can repro in v2.0/v2.1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
See comment 11 for video of issue. Flipped tracking flags according to comment 9's results.

This issue is also similar to bug 1159343.
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(rmitchell) → needinfo?(ktucker)
Keywords: qawanted
(In reply to Shine from comment #9)
> Because I have no .ogv video file, I just used the video in comment 5 to
> reproduce this Problem.
> Problem cannot be reproduced in latest build of Flame 2.0/2.1/2.2 by the STR
> in comment 0, but it is reproducible in V3.0.
> See attachment: Flame3.0_logcat_1228.txt & Flame3.0_issue can be
> reproduced.mp4

ogv and mp4 uses different classes for video playback. They should be different problem. About mp4, it seems similar to Bug 1170589.
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(npark)
Based on Comment 13, changing title to make sure this bug is about .ogv playback.  (Bug 1170589 covers mp4)
Flags: needinfo?(npark)
Summary: [Video player] larger videos have performance issues in video player → [Video player] larger .ogv videos have performance issues in video player
Marking as 3.0+ since this looks like a regression.
blocking-b2g: 3.0? → 3.0+
John, could you help investigate this issue?
Flags: needinfo?(jolin)
Will check it. Could be the same as bug 1159343.
Flags: needinfo?(jolin)
Assignee: nobody → jolin
Component: Gaia::Video → Video/Audio
Product: Firefox OS → Core
Blocks: 1180703
blocking-b2g: 2.5+ → ---
feature-b2g: --- → 2.5+
OggReader uses the now obsolete sync interface so we are intending to remove it. This bug is probably not worth fixing at this point.
Triage for 2.5.
No longer blocks: 1180703
feature-b2g: 2.5+ → ---
Whiteboard: [2.1-exploratory-2][perf-wanted] → [2.1-exploratory-2]
Component: Audio/Video → Audio/Video: MSG/cubeb/GMP
OggReader is not async.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: oggdemuxer
You need to log in before you can comment on or make changes to this bug.