[Gallery] Crop icons will not appear when editing a image in gallery app

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Gallery
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: SalvadorR, Assigned: pdahiya)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2][priority][2.2 backlog])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Description:
When user attempts to edit a image in the gallery app, if user navigates to the cropping tool, the cropping tool icons will not appear
   
Repro Steps:
1) Update a Flame device to BuildID: 20140922000332
2) Navigate to gallery app
3) Open an image and choose to edit it
4) Select the cropping tool icon
5) Observe cropping tool icons
  
Actual:
Cropping tool icons do not appear in photo edit
  
Expected: 
All cropping tool icons appear properly in photo edit
  
Environmental Variables:
Device: Flame 2.1 (319 mb)
BuildID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 2/5
See attached: Screenshot, Logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8493447 [details]
2014-09-22-12-31-41.png
(Reporter)

Comment 2

3 years ago
Created attachment 8493448 [details]
logcat_20140922_1350.txt
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory] → [2.1-exploratory-2]
(Reporter)

Comment 3

3 years ago
This issue also occurs on Flame 2.0 and Flame 2.2

Actual:
Cropping tool icons do not appear in photo edit

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
(Reporter)

Comment 4

3 years ago
Ignore comment 3, here are the correct Environmental Variables:
-----------------------------------------------------------------
This issue also occurs on Flame 2.0 KK (319mb) and Flame KK 2.2 (319mb)

Actual:
Cropping tool icons do not appear in photo edit

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
(Reporter)

Updated

3 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.2: --- → affected
Not nominating this because of the low repro rate, and the user can get the controls to reappear if they go out and back in edit mode
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 6

3 years ago
Hema, can we get this for 2.2 backlog?  its recoverable, but pretty bad UI when it happens.
Flags: needinfo?(hkoka)

Comment 7

3 years ago
Punam,

Please investigate after release blockers.

Thanks
Hema
Assignee: nobody → pdahiya
Flags: needinfo?(hkoka)
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2][priority][2.2 backlog]
(Assignee)

Comment 8

3 years ago
Failed to replicate the issue with the steps provided in #comment0:

Environmental Variables:
Device: Flame KK 2.2 Master (319mb)
BuildID: 20141001040205
OS Version: 2.2
Firmware: V180

Setting NI flag for QA reporter to update bug with detail STR and check if the issue is still in valid in latest master build. Thanks
Flags: needinfo?(srapanan)
(Reporter)

Comment 9

3 years ago
Issue still repros on the latest build: 20141001000202. Higher chance to repro when attempting to repro issue while gallery is loading images. ex: selecting edit after swiping to several images quickly, while device is still loading images from SD card.
Flags: needinfo?(srapanan)
(Assignee)

Comment 10

3 years ago
(In reply to [:SalvadorR] from comment #9)
> Issue still repros on the latest build: 20141001000202. Higher chance to
> repro when attempting to repro issue while gallery is loading images. ex:
> selecting edit after swiping to several images quickly, while device is
> still loading images from SD card.

Hi Salvador

I am not able to replicate issue with above steps on today's master build Id: 20141006040204 , Flame-KK 

See video: http://youtu.be/r00zQzsnik8

Is there any particular image when you try to edit that displays this bug. Also whats the number of image or reference load (light, heavy, x-heavy) on your flame. It will be great if you can provide a video to help replicate the issue. Thanks
Flags: needinfo?(srapanan)
(Reporter)

Comment 11

3 years ago
X-heavy was ran, before reproing the issue. After attempting to repro this issue many times. I too, no longer experience this issue.
Flags: needinfo?(srapanan)
(Assignee)

Comment 12

3 years ago
(In reply to [:SalvadorR] from comment #11)
> X-heavy was ran, before reproing the issue. After attempting to repro this
> issue many times. I too, no longer experience this issue.

Thanks Salvador for confirming. I am marking bug as Resolved WFM, please feel free to reopen the bug if you see this bug again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.