Closed Bug 1071346 Opened 7 years ago Closed 7 years ago

[Browser Windows Manager] The 'Recent browser window show up here' does not display when the user tap on the Windows Manager button

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1064975
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Whiteboard: [2.1-exploratory-2])

Attachments

(1 file)

Attached file tm.txt
Description:
The 'Recent browser window show up here' does not display when the user tap on the Windows Manager button


Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20140922000332
2) Open the Browser
3) Tap on the icon in the top right-hand corner


Actual:
The recent browser window does not show up

Expected:
Recent browser window show up


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
Build ID: 20140922063004
Gaia: 689c4ad4d8c3e4aa95805a2e49ae6cf786a1ae91
Gecko: 185fc54d29c1
Version: 34.0a2 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Note: Also the rocketbar/search does not function when the user tap on the Windows Manager button


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=cpu0hlucYpg
This issue also reproduces on the Flame 2.1 (319mb), Open C 2.1, and the Flame 2.1 (512mb). The recent browser window does not show up.

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame 2.1 
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Open C 2.1

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.1 (512mb)

Environmental Variables:
Device: Flame 2.1 
Build ID: 20140922000332
Gaia: b3f9b97d16a1ab55f80239d63c1a85c3da3d39ad
Gecko: 2c6e3261c47b
Version: 34.0a2 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

_______________________________________________________________________________________________________________

This issue does not reproduce on the Flame 2.2 (319mb), Open C 2.2, Flame 2.2 KitKat Base (319mb). The recent browser window show up

Flame 2.2 (319mb)

Environmental Variables:
Device: Flame 2.2 
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Open C 2.2

Environmental Variables:
Device: Open_C 2.2
Build ID: 20140922040204
Gaia: c7ef0bf06ce1c98cbe68aa52e2ecd862acb23e9c
Gecko: 53f7f5b6d7bf
Version: 35.0a1 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.2 KitKat Base (319mb)

Device: Flame 2.2
BuildID: 20140922043003
Gaia: 3802009e1ab6c3ddfc3eb15522e3140a96b33336
Gecko: 5e704397529b
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

_________________________________________________________________________________________________________________

This issue does not reproduce on the Flame 2.0 KitKat Base (319mb), Flame 2.0 (319mb), Open_C 2.0, because the browser chrome was not implemented on the device. 

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140922082143
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: dc61f92b855e
Version: 32.0 (2.0)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0 
Build ID: 20140922000331
Gaia: 0658006be8a00fdb5931ee15a0aa353a3ab231ba
Gecko: c0086da55273
Version: 32.0 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory] → [2.1-exploratory-2]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064975
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.