[settings]Volume icons not synchronized

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: ankit93040, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [g+][LibGLA, Dev, B] )

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

Steps to reproduce:

Go to settings->sound
Touch the progress bar & make the volume to 0 for all Media, Notification & Alarm


Actual results:

The GUI icons remains same for volume = 0 & volume!=0


Expected results:

The GUI icons should also change according to volumes
(Reporter)

Updated

3 years ago
Whiteboard: [g+][LibGLA, Dev, B]
(Reporter)

Updated

3 years ago
Component: General → Gaia::Settings
(Reporter)

Updated

3 years ago
Flags: needinfo?(arthur.chen)
This is by design. The icons won't change along with the volumes. Flagging Jenny for evaluating this feature request.
Flags: needinfo?(arthur.chen) → needinfo?(jelee)

Comment 2

3 years ago
When volume is down to 0, the slide bar will no longer contain blue bar area which serves as a proper visual cue. I don't think it's necessary to also change the icon design. Thanks!
Flags: needinfo?(jelee)
(Reporter)

Comment 3

3 years ago
Let me also bring this to your kind notice, Jenny
If we do the volume to 0 in settings app,
then statusbar shows vibration/silent mode depending upon settings vibrate checkbox.

So, I feel that icons should be also be updated in settings app.. Preferably for any new coming branches.
Flags: needinfo?(jelee)

Comment 4

3 years ago
So, there are components on a screen that does not change (like the icons on Setting landing page or titles), there are components that changes (like toggle, checkbox, second line text). The icons in sound settings are by appearance part of the still ones, it would be weird if it suddenly changes when volume is down to 0. Also, the purpose of the icons are to distinguish the "type" of sound setting, not reflecting the state. Hope that makes sense. Thanks!
Flags: needinfo?(jelee)
(Reporter)

Comment 5

3 years ago
Resolving it as wont fix after Jenny'ss comments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.