[Telemetry] No app usage tracking for web browsing

RESOLVED WONTFIX

Status

Firefox OS
Gaia
--
enhancement
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: shinglyu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

4 years ago
# Summary
  Time spent on web browsing is not tracked since there is no browser app.

# Steps
  * (optional) Change the app usage upload interval to 1 min.
  * Enable Wi-Fi or 3G, and enable app usage tracking in Settings > Improve B2G OS > Submit data
  * Open the Browser app.
  * Go to any website, browser for a few minutes.
  * Wait fot the app usage data to be transmitted to the server. 

# Expected
  There should be some record about the browsing activity. 

# Actual
  Nothing about the browsing activity is tracked, except the first few seconds in the search.gaiamobile.org app.

# Reproduction Frequency
  Always
(Reporter)

Updated

4 years ago
Flags: needinfo?(marshall)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
marshall/Ravi,

can you please help triage this?
Flags: needinfo?(rdandu)

Comment 3

4 years ago
Needed for 2.1. App usage time metrics will be inaccurate if this is not fixed.
Assignee: nobody → marshall
Flags: needinfo?(rdandu)
Flags: needinfo?(marshall)
Target Milestone: --- → 2.1 S6 (10oct)

Updated

4 years ago
Status: NEW → ASSIGNED
Punting for 2.1, the browser app will be shown as system for now..
blocking-b2g: 2.1? → ---

Comment 5

4 years ago
This is coming very late for 2.1 and there seems to be other important bugs that Marshall should address. Moving assignee to nobody 

Ravi: Please add this to the backlog for next release.
Assignee: marshall → nobody
Severity: normal → enhancement
blocking-b2g: --- → backlog
Target Milestone: 2.1 S6 (10oct) → ---
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
(Reporter)

Comment 6

3 years ago
New test result for 2.2:

STR:
1. Tap the "Browser" app, wait for 5 sec
2. Tap any tab in the "TOP SITES" section
3. Browse for a few seconds
4. Press the home button

Expected:
The first 5 sec in the search.gaiamobile.org should be tracked in app usage ping

Actual:
Nothing is recorded in app usage ping

Notes:
Perhaps we need to track the search.gaiamobile.org usage in this case.

Comment 7

2 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.