Cancel button from “write a review” section does not work

VERIFIED FIXED in 2014-10-21

Status

Marketplace
Consumer Pages
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Madalin Cotetiu, Assigned: mat)

Tracking

({regression})

Avenir
2014-10-21
x86_64
Gonk (Firefox OS)
regression
Points:
---

Details

(Whiteboard: [repoman])

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Sign in MP-Stage app on Inari.
2. Load details page for an app.
3. Click the Write a review button
4. Tap Cancel button.

Expected results:
The user is redirected to the app detail page.

Actual results:
Nothing happens.

Notes/Issues:
Issue is reproducing in stage and production using FFOS 1.4 (Inari) FFOS 2.1 (Flame) and on Android 4.2.1
Not reproducing using FF35 (Win7)
(Reporter)

Comment 1

4 years ago
Ashes ID: 927d0

Updated

4 years ago
Priority: -- → P2
Whiteboard: [repoman]

Updated

4 years ago
Target Milestone: 2014-09-23 → ---
(Assignee)

Updated

4 years ago
Assignee: nobody → mpillard
(Assignee)

Comment 2

4 years ago
Probably a regression from https://github.com/mozilla/fireplace/commit/5d69926ddb17cec99dca67ab091b98103ae3110d - the refresh was a good thing on mobile, since we were on a different page.
Keywords: regression
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Oh, doy. That event listener was for mobile. My bad for not catching that.
(Assignee)

Comment 4

4 years ago
Fixed in https://github.com/mozilla/fireplace/commit/71ac44d5e9172b6ae1c28479746b2a0765adc574
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-10-14
(Reporter)

Comment 5

4 years ago
Verified in FFOS 1.4 (Inari) FFOS 2.1 (Flame) and on Android 4.2.1
Now when taping the cancel button the user is redirected to the reviews page . The expected result would be to be redirected to the app detail page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

4 years ago
Should be fixed in https://github.com/mozilla/fireplace/commit/7bb542c6d96ce2e760e344fbb38f66a565d566c4 - You'll always land on the app detail page when cancelling the modal on mobile, as before.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Target Milestone: 2014-10-14 → 2014-10-21
(Reporter)

Comment 7

4 years ago
Verified as fixed in FFOS 1.4 (Inari) FFOS 2.1 (Flame) and Android 4.2.1
Closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.