Closed Bug 1071650 Opened 10 years ago Closed 9 years ago

Incorrect static rendering with mac APZC

Categories

(Core :: Panning and Zooming, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: BenWa, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached image Screenshot 2014-09-23 12.06.47.png (obsolete) —
I see some pages render incorrectly with APZC forced on. The easier to reproduce is my wordpress dashboard. The incorrect rendering is permanent. I'll look for a public testcase to reproduce.
Blocks: apz-desktop
Better STR:
1) Open https://bugzilla.mozilla.org/show_bug.cgi?id=1013364
2) Mouse over the CC list (it should be scrollable)
3) Fling to scroll down

I also sometimes get a red square on the top right of the screen indicated APZC failures.
Attachment #8493820 - Attachment is obsolete: true
Attachment #8493828 - Attachment is patch: false
Attachment #8493828 - Attachment mime type: text/plain → image/png
In my case after I do these STR I don't see incorrect rendering, but I do see a giant green layer border around where you see the incorrect rendering, and my two-finger trackpad scroll stops scrolling the CC list and always scrolls the page.
Some of the page content (e.g. crash signature, QA whiteboard) ends up on another layer that sits on top of the scrollable subframe for the CC list. Presumably this layer has some transparency and so we're not doing proper hit detection for this scenario in the APZ code. That would explain the behaviour I'm seeing. I'm not sure why for you the CC list disappears entirely, but it also looks like that layer has a darker background color for you, so maybe that layer on top is just painting over the layer underneath that has the CC list.
The layerization and scrolling behaviour seems good now on the bugzilla page.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: