Closed Bug 1071690 Opened 7 years ago Closed 6 years ago

WebGL content disappears

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: snorp, Unassigned)

References

()

Details

(Keywords: regression, reproducible)

If I go to http://threejs.org/examples and try a few of the things on the left, I often get a few frames of the animation and then it disappears. Sometimes I also need to pan/zoom around to get that to happen.
Used the buffer geometry demo, and after a few frames I get a black frame.

Last good revision: 2b29602d9850
First bad revision: 17299e0f1029

Pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2b29602d9850&tochange=17299e0f1029
tracking-fennec: --- → ?
Looks like most of the changes from bug 1022612 were also backed out there, but hard to believe it's not related. roc?
Flags: needinfo?(roc)
1022612 relanded.

I don't see this on Linux. So I'm not sure what's going on. Is this Android only?
Flags: needinfo?(roc)
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #3)
> 1022612 relanded.
> 
> I don't see this on Linux. So I'm not sure what's going on. Is this Android
> only?

Yup.
Assignee: nobody → roc
tracking-fennec: ? → 35+
Nightly seems ok now. Can we figure out when this got fixed?
Kevin volunteered to bisect this :)
Flags: needinfo?(kbrosnan)
tracking-fennec: 35+ → 37+
roc, are you working on this?
Flags: needinfo?(roc)
No. I assumed from comment #6 that I was off the hook :-)
Flags: needinfo?(roc)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #5)
> Nightly seems ok now. Can we figure out when this got fixed?

What versions still show this problem?
tracking-fennec: 37+ → ?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
tracking-fennec: ? → ---
Flags: needinfo?(kbrosnan)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.