Add unit tests to validate json files in tools repo to avoid bustage

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: pmoore, Assigned: pmoore)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
Add unit tests to avoid invalid json files getting checked in, e.g. bug 1071518.
(Assignee)

Comment 1

3 years ago
Created attachment 8493907 [details] [diff] [review]
bug1071746_tools_v1.patch

I'll scan other repos tomorrow to see if we want similar ones for other repos too, and will add them to this bug.
Assignee: nobody → pmoore
Status: NEW → ASSIGNED
Attachment #8493907 - Flags: review?(coop)
(Assignee)

Updated

3 years ago
See Also: → bug 1071518
(Assignee)

Updated

3 years ago
See Also: → bug 1066823

Comment 2

3 years ago
This is great, thank you for following up on root causes! :-)
(Assignee)

Updated

3 years ago
Attachment #8493907 - Flags: review?(coop) → review?(mgervasini)
(Assignee)

Comment 3

3 years ago
Created attachment 8495834 [details] [diff] [review]
bug1071746_tools_v2.patch

Based on your initial feedback on IRC, an updated patch...
Attachment #8493907 - Attachment is obsolete: true
Attachment #8493907 - Flags: review?(mgervasini)
Attachment #8495834 - Flags: review?(mgervasini)
Comment on attachment 8495834 [details] [diff] [review]
bug1071746_tools_v2.patch

Review of attachment 8495834 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Pete, works for me. Could you remove "#!/usr/bin/env python" before committing it? (the other tests do not have it)
Attachment #8495834 - Flags: review?(mgervasini) → review+
(Assignee)

Updated

3 years ago
Attachment #8495834 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
The three new tests passed:

http://10.134.48.37:8080/job/tools_tests/897/testReport/mozilla_buildtools.test.test_json_validity/JsonValidityTest/
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.