Intermittent test_scriptProcessorNodeChannelCount.html | application crashed [@ mozilla::gl::GLContext::MakeCurrent(bool)]

RESOLVED DUPLICATE of bug 1067569

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1067569
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash})

Trunk
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=48677625&tree=B2g-Inbound

b2g_emulator_vm b2g-inbound opt test mochitest-3 on 2014-09-23 05:28:04 PDT for push ad6ad46eb0a1
slave: tst-linux64-spot-544

06:37:12     INFO -  667 INFO TEST-START | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html
06:37:15     INFO -  668 INFO TEST-OK | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | took 2377ms
06:37:21     INFO -  -*- NetworkService: NetworkService shutdown
06:37:21     INFO -  JavaScript error: resource://gre/modules/BrowserElementParent.jsm, line 300: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.isDeadWrapper]
06:37:21     INFO -  JavaScript error: resource://gre/modules/BrowserElementParent.jsm, line 300: NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.isDeadWrapper]
06:37:22     INFO -  JavaScript error: resource://gre/modules/IndexedDBHelper.jsm, line 121: UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code.
06:37:22     INFO -  JavaScript error: jar:file:///system/b2g/omni.ja!/components/B2GAppMigrator.js, line 125: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]
06:37:29     INFO -  mozcrash Downloading symbols from: http://pvtbuilds.pvt.build.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/b2g-inbound-emulator/20140923051244/b2g-35.0a1.en-US.android-arm.crashreporter-symbols.zip
06:37:49  WARNING -  PROCESS-CRASH | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | application crashed [@ mozilla::gl::GLContext::MakeCurrent(bool)]
06:37:49     INFO -  Crash dump filename: /tmp/tmpulWYSG/5a014566-f1cd-5e42-734947be-1696bd68.dmp
06:37:49     INFO -  Operating system: Android
06:37:49     INFO -                    0.0.0 Linux 2.6.29-g41a03df #22 Thu Jun 26 10:59:09 CST 2014 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20140923.063241:eng/test-keys
06:37:49     INFO -  CPU: arm
06:37:49     INFO -       0 CPUs
06:37:49     INFO -  Crash reason:  SIGSEGV
06:37:49     INFO -  Crash address: 0x250
06:37:49     INFO -  Thread 20 (crashed)
06:37:49     INFO -   0  libxul.so!mozilla::gl::GLContext::MakeCurrent(bool) [GLContext.h:ad6ad46eb0a1 : 2742 + 0x0]
06:37:49     INFO -       r4 = 0x4793f8a0    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc58    lr = 0x40e908c1    pc = 0x40e3fe3e
06:37:49     INFO -      Found by: given as instruction pointer in context
06:37:49     INFO -   1  libxul.so!mozilla::layers::CompositableDataGonkOGL::DeleteTextureIfPresent() [TextureHostOGL.cpp:ad6ad46eb0a1 : 164 + 0x5]
06:37:49     INFO -       r4 = 0x4793f8a0    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc60    pc = 0x40e908c1
06:37:49     INFO -      Found by: call frame info
06:37:49     INFO -   2  libxul.so!mozilla::layers::CompositableDataGonkOGL::ClearData() [TextureHostOGL.cpp:ad6ad46eb0a1 : 147 + 0x3]
06:37:49     INFO -       r4 = 0x47e70400    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc68    pc = 0x40e908e3
06:37:49     INFO -      Found by: call frame info
06:37:49     INFO -   3  libxul.so!mozilla::layers::CompositableHost::Detach(mozilla::layers::Layer*, unsigned int) [CompositableHost.h:ad6ad46eb0a1 : 239 + 0x5]
06:37:49     INFO -       r4 = 0x47e70400    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc70    pc = 0x40e73f85
06:37:49     INFO -      Found by: call frame info
06:37:49     INFO -   4  libxul.so!mozilla::layers::ThebesLayerComposite::CleanupResources() [ThebesLayerComposite.cpp:ad6ad46eb0a1 : 163 + 0x9]
06:37:49     INFO -       r4 = 0x47e70400    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc78    pc = 0x40e74a11
06:37:49     INFO -      Found by: call frame info
06:37:49     INFO -   5  libxul.so!mozilla::layers::ThebesLayerComposite::Destroy() [ThebesLayerComposite.cpp:ad6ad46eb0a1 : 77 + 0x5]
06:37:49     INFO -       r4 = 0x47e70400    r5 = 0x00000004    r6 = 0x00000008    r7 = 0x00000004
06:37:49     INFO -       r8 = 0x00000004    r9 = 0x47ec7b88   r10 = 0x00000000    fp = 0x466ffd98
06:37:49     INFO -       sp = 0x466ffc80    pc = 0x40e74989
06:37:49     INFO -      Found by: call frame info
(Reporter)

Comment 1

4 years ago
Nevermind, just a variation on bug 1067569.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1067569
You need to log in before you can comment on or make changes to this bug.