Closed Bug 1071783 Opened 6 years ago Closed 6 years ago

Crash at CPrivAlloc::operator delete(void*) within Nv3DVUtils::Initialize

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1066139

People

(Reporter: benjamin, Unassigned)

Details

(Keywords: crash)

Crash Data

The signature [@ CPrivAlloc::operator delete(void*) ] spiked in FF33 with OMTC. Previously this signature was only associated with a networking crash in Windows, but the spike is different: it's under

Nv3DVUtils::Initialize()

And specifically within this call:

HRESULT hr = CoCreateInstance(CLSID_NV3DVStreaming, nullptr, CLSCTX_INPROC_SERVER, IID_INV3DVStreaming, (void**)(getter_AddRefs(m3DVStreaming)));

See 4381a74b-fb72-47db-8c8e-fc6ff2140915 for an example.

This is the compositor thread, and the most likely explanation I can come up with is that we haven't properly called CoInitialize here, so it's illegal to call CoCreateInstance. Bas is that a possibility?
Flags: needinfo?(bas)
Keywords: crash
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066139
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #0)
> This is the compositor thread, and the most likely explanation I can come up
> with is that we haven't properly called CoInitialize here, so it's illegal
> to call CoCreateInstance. Bas is that a possibility?

This makes sense, this code used to run on the main thread before OMTC. The feature itself is only supported with D3D9 layers so we are talking about removing it (bug 1066139 puts it behind a pref that is off by default as a first step), so we may not have to fix that.
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.