Closed Bug 1071787 Opened 7 years ago Closed 7 years ago

[SMS] "Go to Camera" button cancels popup when attempting to attach a video with no videos on device

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jdegeus, Assigned: rnicoletti)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-2])

Attachments

(2 files)

Description:
When users do not have any videos on their device and select to attach a video to a new email or to a MMS the users will receive a popup stating "Add videos to get started - Load videos onto the memory card" with a button stating "Go to Camera". Upon selecting "Go to Camera" button, users will be returned to their MMS/Email rather than to the camera app itself.
   
Setup:
Confirm no Videos are present on device memory or SD card

Repro Steps:
1) Update a Flame device to BuildID: 20140923003005
2) Select Messaging/SMS
3) Create new message> Select Attachements> Videos
4) Select "Go to Camera" and observe
  
Actual:
"Go to Camera" button functions as a cancel button when attempting to attach a video to email/MMS if no videos are present
  
Expected: 
Users are brought to Camera rather than canceling popup menu
  
Environmental Variables:
Device: Flame 2.1 (319mb)
BuildID: 20140923003005
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 3/3
See attached: Video and Logcat
http://youtu.be/U-ydhiHpd
This issue DOES occur on Flame 2.2 JB(319mb), Flame 2.2 KK (319mb), Flame 2.1 JB (319mb), Flame 2.1 KK (512mb), Open C 2.2, Open C 2.1

Actual: "Go to Camera" button cancels out of menu when attemtping to attach a video to a email/mms when users lack any videos


Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2
BuildID: 20140923073003
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9e193395b912
Version: 35.0a1 (2.2)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.2 Jelly Bean Base (319mb)

Enviromental Variables:
Device: Flame 2.2 Master
BuildID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.2 Open C

Environmental Variables:
Device: Open_C Master
Build ID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1 
BuildID: 20140923003005
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.1 Jelly Bean Base (319mb)

Enviromental Variables:
Device: Flame 2.1
BuildID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

2.1 Open C

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---------------------------------------------------------------------

This issue DOES NOT occur on Flame 2.0 JB (319mb), Flame 2.0 KK (319mb), Open C 2.0

Actual: Button on menu states "Cancel" rather than "Go to Camera"

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140923063014
Gaia: 6449cc35a8f0704d95acac374ba857bde4b86d6c
Gecko: b930730dba81
Version: 32.0 (2.0)
Firmware Version: 123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 Jelly Bean Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0)
Firmware Version: 123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Video issue :)
Component: Gaia::SMS → Gaia::Video
Flags: needinfo?(rnicoletti)
It _might_ be a System/Window Management issue though. Cc alive on this as well.
The video was removed or deprecated. And I don't see any 'go to camera' after step 3. What's missing?
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #4)
> The video was removed or deprecated.

I mean the youtube link in comment 0.

> And I don't see any 'go to camera'
> after step 3. What's missing?
NI reporter for the missing video link.
Flags: needinfo?(jdegeus)
Must have been a copy/paste issue. 

Video URL has been updated: http://youtu.be/U-ydhiHpd-I
Flags: needinfo?(jdegeus)
[Blocking Requested - why for this release]:

Bad user experience. Button appears to be broken and never opens the camera app. Also a regression.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140825110152
Gaia: 9f79ffc8f284cda736d2ed64b45c11e9ac578e6a
Gecko: 02f3a6a8fb8d
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140825113152
Gaia: 1934a2297ffc0d90424cd9cd3294c4a8c74a7333
Gecko: 4f237a7bd81a
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken Gaia & Last Working Gecko - button label says 'Go to Camera' (repro)
Gaia: 1934a2297ffc0d90424cd9cd3294c4a8c74a7333
Gecko: 02f3a6a8fb8d

First Broken Gecko & Last Working Gaia - button label says 'Cancel' (no repro)
Gaia: 9f79ffc8f284cda736d2ed64b45c11e9ac578e6a
Gecko: 4f237a7bd81a

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/9f79ffc8f284cda736d2ed64b45c11e9ac578e6a...1934a2297ffc0d90424cd9cd3294c4a8c74a7333

Caused by Bug 1047215
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
broken by Bug 1047215 ? The patch author already has a NI on them (comment 2)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: pcheng
Blocking Reason: Bad User experience with broken navigation. Button label says "Go to Camera", but leads back to Messages. Also a regression. 

Russ, please investigate.

Thanks
Hema
Assignee: nobody → rnicoletti
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S6 (10oct)
From my investigation, the regression is that during a pick activity, when there are no videos on the device, the overlay menu button says "Go to Camera" instead of "Cancel". As far as I can tell the behavior of the Video and the Gallery app has always been to show a "Cancel" button in this situation. Therefore, the regression is not that the "Go to Camera" button is broken, it is that the button label should be "Cancel" instead of "Go to Camera". I am working on fixing this.
Flags: needinfo?(rnicoletti)
Status: NEW → ASSIGNED
Comment on attachment 8497145 [details] [review]
Github PR https://github.com/mozilla-b2g/gaia/pull/24530

Thanks Russ for the patch, I especially like that the patch is also fixing cancel button to show for upgrade, no card and plugged-in overlays for video pick activity, it has my r+.
Attachment #8497145 - Flags: review?(pdahiya) → review+
Master:

https://github.com/russnicoletti/gaia/commit/4c55e316100ba3306564a60c457f6e72d879e07f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Please ignore commit link in comment 15. The link to the commit in the gaia repo is:

https://github.com/mozilla-b2g/gaia/commit/011d2ff0a746e5c3e4dfca8d6e9b8ee8b8f64af3
Please nominate this patch for Gaia v2.1 approval when you get a chance :)
Flags: needinfo?(rnicoletti)
Comment on attachment 8497145 [details] [review]
Github PR https://github.com/mozilla-b2g/gaia/pull/24530

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression caused by bug 1047215

[User impact] if declined:
Bad user experience. User is shown a button they would like to use to bring up the camera app but it does not work. Also, this is a regression.

[Testing completed]:
On device testing and unit tests. 

[Risk to taking this patch] (and alternatives if risky):
Risk is low. It is a minor change to a single video app javascript file that affects only the flow that is broken.

[String changes made]: none.
Attachment #8497145 - Flags: approval-gaia-v2.1?(bbajaj)
Flags: needinfo?(rnicoletti)
This issue is verified on Flame 2.2:

Flame 2.2 KitKat Base (319mb)(Full Flash)
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141002093155
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 5d6ec4dddf14
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.

The button says "Cancel" instead of "Go to Camera".
====================================================
Leavingn verifyme keyword to verify 2.1 when patch is uplifted for 2.1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8497145 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
This issue is verified fixed in Flame 2.1

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The button says "Cancel" instead of "Go to Camera".
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Hi Pi Wei,

Do you know if there is there an automated test for this use case?
Flags: needinfo?(pcheng)
No I do not know the answer for this question. Needinfo Robert Chira who does automations.
Flags: needinfo?(pcheng) → needinfo?(robert.chira)
We do not have a test case for the STR from comment 0.
The test we have for sms with attachments taps on "Camera" in the activities list instead of "Videos" then camera.

Link to test:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_with_attachments.py
Flags: needinfo?(robert.chira)
You need to log in before you can comment on or make changes to this bug.