Closed Bug 1071934 Opened 5 years ago Closed 5 years ago

[shadow-dom] <video> in shadow-dom crashes app

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: wilsonpage, Assigned: wchen)

Details

Attachments

(1 file)

Injecting a <video> element into the shadowRoot instantly crashes FxOS apps. This doesn't reproduce on desktop Firefox.
STEPS:

1. Flash device with this branch [1]
2. Launch Camera app
3. Observe app crashes

[1] https://github.com/wilsonpage/gaia/tree/1071934-test-case
crash-stat? Or do we not get those on FFOS?
Looks like this is yet another case of GetCurrentDoc() vs GetComposedDoc()
(In reply to William Chen [:wchen] from comment #3)
> Created attachment 8494188 [details] [diff] [review]
> Used GetComposedDoc() in nsVideoFrame
> 
> Looks like this is yet another case of GetCurrentDoc() vs GetComposedDoc()

Do we have suitable reviewer for this patch?
Comment on attachment 8494188 [details] [diff] [review]
Used GetComposedDoc() in nsVideoFrame

How did I miss this.
Attachment #8494188 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/2489b63b2493
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.