Closed Bug 1071941 Opened 5 years ago Closed 4 years ago

[Vertical Homescreen] Long title is not wrapped on delete confirmation dialog.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: ychung, Unassigned)

References

Details

(Whiteboard: [2.1-exploratory-2])

Attachments

(3 files)

Description:
When the user changes the bookmark to a long title and try to delete it, the title is not properly wrapped inside the screen on the delete confirmation dialog.

Pre-requisite: Have a bookmark on homescreen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140923003005.
2) Long tap a bookmark on homescreen, and enter the Edit mode.
3) Tap the bookmark again to enter Edit bookmark mode.
4) Add multiple characters to make the title very long.
5) Select 'Done'.
6) Long tap the bookmark again.
7) Select the red 'X' on the bookmark.
8) Observe the delete confirmation dialog.
  
Actual:
The title is not completely shown on the screen. It appears to be cut off on the right side of the screen. 

Expected: 
The long title is wrapped properly inside the screen.
  
Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140923003005
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes:
The same issue also occurs with a long Smart Collection title as well.

See also:
https://bugzilla.mozilla.org/show_bug.cgi?id=1061441
 
Repro frequency: 100%
See attached: logcat, screenshot
This issue also reproduces on Flame 2.1 (512mb, KK), Flame 2.1 (319mb, JB), Open C 2.1:

Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140923003005
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.1 Jelly Bean Base (319mb)

Enviromental Variables:
Device: Flame 2.1
BuildID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

2.1 Open C

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140923000204
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The title is not completely shown on the screen.
On v.2.0 and v.2.2, the long title is wrapped inside the screen. However, there is no scroll bar that allows the user to see the whole text in the dialog:

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140923063014
Gaia: 6449cc35a8f0704d95acac374ba857bde4b86d6c
Gecko: b930730dba81
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.0 Jelly Bean Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140923000205
Gaia: 8d7f2ac85f3154bdb149d67e5c2f9b035f5e4105
Gecko: 6dd19beda1c2
Version: 32.0 (2.0)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device:  Flame 2.2 Master
BuildID: 20140923073003
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9e193395b912
Version: 35.0a1 (2.2)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.2 Jelly Bean Base (319mb)

Enviromental Variables:
Device: Flame 2.2 Master
BuildID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.2 Open C

Environmental Variables:
Device: Open_C Master
Build ID: 20140923040203
Gaia: 3c898380b47f298cd3b7a0dacb3a6529e94322d4
Gecko: 790f41c631cc
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker) → needinfo?(dharris)
Just to confirm, the title is not wrapped in v2.1 because this bug 1061441 was not uplifted to 2.1. It only lives in v2.2. BTW the scroll feature is not implemented and this will be the patch for this bug
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Depends on: 1061441
not nominating this as a blocker, as the user can still see enough of the title on the confirmation screen to know which app will be deleted.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Duplicate of this bug: 1075409
Hi Mukesh, if you want to take this bug about confirm BB feel free
Assignee: crdlc → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(mukeshk1990)
We can insert the <h1> and <p> elements within a container with overflow-y: auto but this does not work for this workaround:

https://github.com/mozilla-b2g/gaia/blob/master/shared/elements/gaia_confirm/script.js#L18

Do you know if this will be fixed?
Flags: needinfo?(kgrandon)
Ah, so this depends on bug 918288? Ok, I'm adding a dependency on it then. It seems like we'd have to dig in to see if there's some workaround we can do - off the top of my head I'm not sure.
Depends on: 918288
Flags: needinfo?(kgrandon)
Hi Cristian,
As per your comments,
This will require change shared gaia building blocks and some thing related to APZ
since we cannot directly make it overflow.
I think its better if this issue is fixed from your side
Thank you.
Flags: needinfo?(mukeshk1990)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.