Location-bar autocomplete doesn't highlight the trailing slash that it adds, & leaves it straggling if I hit backspace. (So "http://b" completes to "http://bing.com/", & backspace makes it "http://b/")

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR:
 1. Start Firefox with e10s enabled, with an otherwise-fresh profile.

 2. Start typing a HTTPS "www" url into the location bar -- in particular, type this:
  https://w

   ---> It autocompletes to https://wikipedia.org/, with "ikipedia.org" highlighted, but **not the trailing slash**.

 3. Hit backspace to try to clear the autocompleted text, or just keep typing some other characters.

ACTUAL RESULTS: You're left with a trailing slash that you didn't type. (If you hit backspace, you're left with "https://w/".  If you continued typing, you're left with e.g. "https://www/")

EXPECTED RESULTS: The full autocompleted portion (including the trailing slash) should've been highlighted and overwritten/removed.

NOTE: This also happens with http://bing.com (and probably other URLs as well; these ones just happen to be pre-populated in our places database).

If you type in:
   http://b
then it autocompletes to "http://bing.com/", with only "ing.com" highlighted (not the trailing slash).  And then if you hit backspace, you get "http://b/"
In practice, this bug means that if you just start typing "https://www.whatever.com" into your URLbar, you end up getting a trailing slash inserted to the right of your cursor, as you're typing, which is a bit jarring & annoying.
Summary: [e10s] In E10s mode, location-bar autocomplete leaves a trailing "/" that isn't removed if I hit backspace → [e10s] In E10s mode, location-bar autocomplete doesn't highlight a trailing "/", and leaves it straggling behind if I hit backspace
tracking-e10s: --- → +
Apologies -- looks like this has nothing to do with e10s. Not sure why I thought it did; I must've tested insufficiently.

In any case: I can reproduce, using the STR, without enabling e10s.

Regression range:
Last good revision: 98ea98c8191a (2014-09-11)
First bad revision: 2db5b64f6d49 (2014-09-12)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=98ea98c8191a&tochange=2db5b64f6d49

Inbound range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f5ad5364a2df&tochange=3bb9480fbed8

Suspected:
{
fb4b70803019	Blair McBride — Bug 1065265 - Improve infrastructure dealing with moz-action: autocomplete results. r=mak
}
Blocks: 1065265
tracking-e10s: + → ---
Keywords: regression
Summary: [e10s] In E10s mode, location-bar autocomplete doesn't highlight a trailing "/", and leaves it straggling behind if I hit backspace → Location-bar autocomplete doesn't highlight a trailing "/", and leaves it straggling behind if I hit backspace
Summary: Location-bar autocomplete doesn't highlight a trailing "/", and leaves it straggling behind if I hit backspace → Location-bar autocomplete doesn't highlight the trailing slash that it adds, & leaves it straggling if I hit backspace. (So "http://b" completes to "http://bing.com/", & backspace makes it "http://b/")
I cannot reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.