Improve spidermonkey shell builds

RESOLVED FIXED

Status

Release Engineering
Mozharness
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

({leave-open})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1915] )

Attachments

(6 attachments)

(Assignee)

Description

3 years ago
Mainly, I want to make these run jstests and jsapi-tests, but there are other improvements queued up too.
(Assignee)

Comment 1

3 years ago
Created attachment 8494122 [details] [diff] [review]
Run in development mode if no properties file is given

Much easier to do test runs locally with this. It no longer does stupid stuff like looking for /tools/gcc on developer runs.
Attachment #8494122 - Flags: review?(terrence)
(Assignee)

Comment 2

3 years ago
Created attachment 8494124 [details] [diff] [review]
Add a --dep option for a depend build that does not blow away the objdir
Attachment #8494124 - Flags: review?(terrence)
(Assignee)

Comment 3

3 years ago
Created attachment 8494125 [details] [diff] [review]
Port to msys

I tried this. It even seems to work.
Attachment #8494125 - Flags: review?(terrence)
(Assignee)

Comment 4

3 years ago
Created attachment 8494126 [details] [diff] [review]
Use --enable-nspr-build instead of building NSPR manually

Given how much pain it was to implement --enable-nspr-build, I really ought to make use of it.

Actually, I suspect the msys build will only work with this patch applied, but I'm not sure and I don't care to find out.
Attachment #8494126 - Flags: review?(terrence)
(Assignee)

Comment 5

3 years ago
Created attachment 8494129 [details] [diff] [review]
Run jstests and jsapi-tests on the shell builds

This was the main point of this whole exercise. I don't know of any jobs this will break (eg I don't think we do shell builds for b2g), but I guess I'll find out.
Attachment #8494129 - Flags: review?(terrence)
Attachment #8494122 - Flags: review?(terrence) → review+
Comment on attachment 8494124 [details] [diff] [review]
Add a --dep option for a depend build that does not blow away the objdir

Review of attachment 8494124 [details] [diff] [review]:
-----------------------------------------------------------------

::: scripts/spidermonkey_builds/spidermonkey.sh
@@ +111,5 @@
>  else
>    CONFIGURE_ARGS=$(cat $SPIDERDIR/$VARIANT)
>  fi
>  
>  # Always do clobber builds. They're fast.

Please fix the comment too.
Attachment #8494124 - Flags: review?(terrence) → review+
Attachment #8494125 - Flags: review?(terrence) → review+
Comment on attachment 8494126 [details] [diff] [review]
Use --enable-nspr-build instead of building NSPR manually

Review of attachment 8494126 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #8494126 - Flags: review?(terrence) → review+
Comment on attachment 8494129 [details] [diff] [review]
Run jstests and jsapi-tests on the shell builds

Review of attachment 8494129 [details] [diff] [review]:
-----------------------------------------------------------------

This will probably be exciting.
Attachment #8494129 - Flags: review?(terrence) → review+
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1061761
(Assignee)

Updated

3 years ago
Attachment #8494122 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8494124 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8494125 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8494126 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Attachment #8494129 - Flags: checked-in+
(Assignee)

Comment 10

3 years ago
There is a decent chance that this will break all of the SM(...) builds because of the added tests. (They passed locally, but that only goes so far.)

http://hg.mozilla.org/build/tools/rev/d953984b2f6c
http://hg.mozilla.org/build/tools/rev/07cc11ccb05c
http://hg.mozilla.org/build/tools/rev/9a3b2019ad5d
http://hg.mozilla.org/build/tools/rev/9fb4b6a69330
http://hg.mozilla.org/build/tools/rev/044ee8c9e8fc
07cc11ccb05c unset exec mode on scripts/spidermonkey_builds/spidermonkey.sh, which is causing:

/usr/bin/env: scripts/scripts/spidermonkey_builds/spidermonkey.sh: Permission denied

http://ftp.mozilla.org/pub/mozilla.org/spidermonkey/try-builds/npierron@mozilla.com-61c874da1e3c/try-linux-debug/try_linux-debug_spidermonkey-arm-sim-bm76-try1-build308.txt.gz
(In reply to Ed Morley [:edmorley] from comment #11)
> 07cc11ccb05c unset exec mode on scripts/spidermonkey_builds/spidermonkey.sh,
> which is causing:
> 
> /usr/bin/env: scripts/scripts/spidermonkey_builds/spidermonkey.sh:
> Permission denied
> 
> http://ftp.mozilla.org/pub/mozilla.org/spidermonkey/try-builds/
> npierron@mozilla.com-61c874da1e3c/try-linux-debug/try_linux-
> debug_spidermonkey-arm-sim-bm76-try1-build308.txt.gz

Fixed:

https://hg.mozilla.org/build/tools/rev/690e81485930
(Assignee)

Comment 13

3 years ago
Created attachment 8495582 [details] [diff] [review]
Make check-jstests actually run tests

This one shouldn't actually land until we decide what tests we really want to run. This would be a big and slow addition to all these jobs. Discussion on IRC is tending towards identifying the slowest tests and not running them with the interpreter. (Perhaps in addition to --skip-slow we could add --skip-interpreted-slow or something.)
Attachment #8495582 - Flags: review?(terrence)
(Assignee)

Updated

3 years ago
Keywords: leave-open
Attachment #8495582 - Flags: review?(terrence) → review+

Updated

3 years ago
Component: Release Automation → Mozharness
QA Contact: bhearsum → jlund

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1915]
(Assignee)

Updated

3 years ago
Depends on: 1101662
(Assignee)

Comment 14

2 years ago
Comment on attachment 8495582 [details] [diff] [review]
Make check-jstests actually run tests

Review of attachment 8495582 [details] [diff] [review]:
-----------------------------------------------------------------

This ended up getting done in a separate bug.
Attachment #8495582 - Flags: review+
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.