Everything.me results do not open in previously launched window

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
P1
normal
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: FredM, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe][2.1-exploratory-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8494153 [details]
logcat_20140923_1609.txt

Description:
While in Twitter App, when the User taps the Home button and the taps on the Twitter icon again, the User is NOT taken to the previous screen

Repro Steps:
1) Update a Flame to 20140923003005
2) Launch "social" App
3) Tap on "Twitter" icon > login into Twitter
4) Go to any page like "Me"
5) Tap on "Home" button
6) Tap on "Twitter" icon
7) Observe what page you are in


Actual:
User is NOT taken to the previous screen


Expected:
User is taken back to the previous page

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140923003005
Gaia: 3742913e11f69e789dcb0aa0dedf2e5572da0129
Gecko: df42b05782aa
Version: 34.0a2
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
See attached: video clip, logcat: http://youtu.be/704MGDND39k
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue is reproducible on Flame 2.2 KitKat (319mb)

Result: While in Twitter App, when user taps the home button and then taps the Twitter icon again,the User is NOT taken back to the previous page


Environmental Variables:
Device:  Flame 2.2 Master (319mb)
BuildID: 20140923073003
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9e193395b912
Version: 35.0a1 (2.2)
Firmware: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

This issue is NOT reproducible on Flame 2.0 KitKat (319mb)

Result: While in Twitter App, when user taps the home button and then taps the Twitter icon again,the User IS taken back to the previous page

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140923063014
Gaia: 6449cc35a8f0704d95acac374ba857bde4b86d6c
Gecko: b930730dba81
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Is this reproducible with a 2.2 Flame with full memory? Trying to figure out if its memory related.
(Reporter)

Comment 3

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Is this reproducible with a 2.2 Flame with full memory? Trying to figure out
> if its memory related.

This issue is NOT reproducible on a 2.2 Flame with full memory


Environmental Variables:
Device: Flame Master (512mb)
Build ID: 20140923073003
Gaia: 37b8a812c642ca616bf9457cb9b71e45261cdfa8
Gecko: 9e193395b912
Version: 35.0a1 (Master)
Firmware Version: 
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Not nominating this as a blocker because the app is not killed, and the user can easliy get to the page they were on before going home
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]: Regression on low memory device on a standard usage pattern.
blocking-b2g: --- → 2.0?
[Blocking Requested - why for this release]: See comment 5.
blocking-b2g: 2.0? → 2.1?
Can we get a regression window?
Keywords: regressionwindow-wanted
One thing to note - when you hit the home button and then select the Twitter icon again (steps 5 and 6), it is NOT re-opening the prior instance of twitter, it is opening and new instance of it. You can verify this by long pressing home to bring up the card view and you will see multiple instances of twitter. if you select one of the prior opened instances of twitter you WILL be on the page you left off on.
QA Contact: jmitchell
This regression window / pushlog is a bit larger than average - there is a chunk of blocked builds. I am only including the Central regression window because the inbound window (which was also blocked by the same issue) was actually larger than the Central Window.


Central Regression Window:

Last Working:
Device: Flame Master
Build ID: 20140825082450
Gaia: a25ae14dbd2fe3e25144a7064efc0cc4e31042b8
Gecko: 23c70481ed91
Version: 34.0a1 (Master)
Firmware Version: v184
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken:
Device: Flame Master
Build ID: 20140826164655
Gaia: ea93363a8c424d65a9ad91438ce6961377a20f98
Gecko: 4f6affdf52b6
Version: 34.0a1 (Master)
Firmware Version: V184
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: a25ae14dbd2fe3e25144a7064efc0cc4e31042b8
Gecko: 4f6affdf52b6
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: ea93363a8c424d65a9ad91438ce6961377a20f98
Gecko: 23c70481ed91

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/a25ae14dbd2fe3e25144a7064efc0cc4e31042b8...ea93363a8c424d65a9ad91438ce6961377a20f98

I believe this issue was caused by Bug 1055761 or possibly bug 1057905
- Starting with 1055761 NI'ing Kevin G. to take a look
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(kgrandon)
Keywords: regressionwindow-wanted
Since we have a regression range, it's probably not a server issue and I am fairly sure this is a window management thing.
Component: Gaia::Everything.me → Gaia::System::Window Mgmt
Whiteboard: [2.1-exploratory-2] → [systemsfe][2.1-exploratory-2]
Renaming this to be a more generic title.
Summary: [Twitter] When in Twitter App, when you tap on "Home" button and then tap on "twitter" icon, the User is NOT taken back to the previous screen → Hosted app window management - User is not taken to previous instance
Duplicate of this bug: 1078188
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
During team-triage we came to the conclusion that this needs more UX discussion and we are not sure what the intended behavior should be. Lets fix it for 2.2 but lets not block 2.1.
blocking-b2g: 2.1? → backlog
Priority: -- → P1
Renaming the title to be more accurate. The alternative is that users can navigate away from an everything.me result, then opening twitter could open up over an un-intended window. I think the current behavior is much more clear. My recommendation is to close this as wontfix.
Flags: needinfo?(kgrandon)
Summary: Hosted app window management - User is not taken to previous instance → Everything.me results do not open in previously launched window
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 15

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.