[soft-home-button] Airplane mode activated page truncated when trying to turn on Wi-Fi hotspot

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: echang, Assigned: Eli)

Tracking

({polish})

unspecified
2.1 S5 (26sep)
x86_64
Linux
polish
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8494433 [details]
2014-09-21-09-03-08.png

### STR
1. Turn on soft home button.
2. Turn on airplan mode. 
3. Turn on Wi-Fi hotspot in Internet sharing

### Actual 
See 2014-09-21-09-03-08.png

### Version
Gaia-Rev        b542080231bb9cdbdb282ab926965ad3f91f7460
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/d614ae398c03
Build-ID        20140923155123
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  27
FW-Date         Thu Sep  4 14:59:02 CST 2014
Bootloader      L1TC10011800
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Gaia::System]
(Assignee)

Updated

4 years ago
Assignee: nobody → eperelman
Status: NEW → ASSIGNED
Keywords: polish
Target Milestone: --- → 2.1 S5 (26sep)
(Assignee)

Comment 1

4 years ago
Created attachment 8494570 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24387
Attachment #8494570 - Flags: review?(etienne)
Comment on attachment 8494570 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24387

The css variable work is starting to pay off :)

(the amount of different dialogs in the system app is crazy!)
Attachment #8494570 - Flags: review?(etienne) → review+
(Assignee)

Comment 3

4 years ago
(In reply to Etienne Segonzac (:etienne) from comment #2)
> The css variable work is starting to pay off :)
> 
> (the amount of different dialogs in the system app is crazy!)

Totally agree, I wish we had a common API for creating all these dialogs.
Master: https://github.com/mozilla-b2g/gaia/commit/2ba5bbb9ddf38850878913da2bf434d2cbe8ab70
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
Comment on attachment 8494570 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24387

Requesting uplift to v2.1 for UX polish.

[Bug caused by] (feature/regressing bug #): bug 1036339
[User impact] if declined: User will see a truncated dialog box with a difficult to press "close" button
[Testing completed]: manually tested, no new tests
[Risk to taking this patch] (and alternatives if risky): very low, single CSS change affecting height of generic dialogs
[String changes made]: n/a
Attachment #8494570 - Flags: approval-gaia-v2.1?
Broken feature
blocking-b2g: --- → 2.1+

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Attachment #8494570 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
This issue is verified on Flame 2.2 and Flame 2.1:

Flame 2.2 KitKat Base (319mb)(Full Flash)
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141002093155
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 5d6ec4dddf14
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The screen is shifted up and the "OK" button is shown properly.
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [COM=Gaia::System][QAnalyst-Triage?] → [COM=Gaia::System][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Integration test added in bug 1077579.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.