Closed Bug 10723 Opened 21 years ago Closed 18 years ago

[RFE] Context menu item to hide image

Categories

(Core :: ImageLib, enhancement, P3)

enhancement

Tracking

()

VERIFIED WONTFIX
Future

People

(Reporter: Crysgem, Unassigned)

References

Details

(Whiteboard: [imglib])

Leer and bare teeth at that annoying banner advertisement? (Right-)Click upon
it for the context menu, and destave it from your lines of HTML display.
Meaning, for those who do not appreciate the metaphor: To cease displaying the
image (remove it entirely from the display). Of course, this would apply to all
manner of images (not solely the animated GIF) and presumably all discrete
visuals included in the document, if the user so chooses. The layout
consequences - I imagine the set of the page would not change, that the pixels
formerly projecting the image would take up the color and/or image of the
background - of such a decision I leave to others.
Target Milestone: M14
What is basically being suggested here is a context menu option for dynamically
setting the 'display' property of the element in question to 'none'.

An interesting idea; the main problem would be working out which element is
being targetted -- after all, we probably wouldn't want this possible for all
the inline elements. And restricting it to <img> elements seems a bit limited.
QA Contact: leger → elig
[Contextual menu bug --- QA Assigning to self.]
Move to M20.
Cool idea. I'm not sure whether making the object's `display: none' entirely 
would be such a great idea, because you'd want to be able to reverse the action 
by using the context menu on the graphic's placeholder icon.

Deobscurificating summary ...
Summary: [RFE] Context-menu (right-click) option to destave images → [RFE] Context menu item to hide image
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy
QA Contact: elig → doronr
*** Bug 61888 has been marked as a duplicate of this bug. ***
From bug 65015:
It'd be nice if Moz had more comprehensive image filter support, most notably
the ability to filter out images based on various criteria like server, path,
size, dimensions, etc. This would be usefull for people on slow connections who
wish to filter out large images, advertisments etc.
*** Bug 65015 has been marked as a duplicate of this bug. ***
I just thought of this feature too, and was unsuprised to find it already in the
database.

The way I see it is this:

Sometimes an image will not download, say if you have got image downloading
turned off. When this happens mozilla is quite happy to display the page with a
blank box and the alt text.

Also, mozilla knows when you bring up the context menu over an image since you
get options like "Save image (pic.png) ...", so that code is in place.

What is needed is a context menu option that tells mozilla to throw away the
image so that it then behaves as if it had never downloaded it in the first
place. Perhaps call it "Remove this image". 

At the same time it would be nice to add the reverse context menu item: if you
bring up the menu over an image that has not been downloaded yet, then it should
offer you the chance to "Download this image" and have it appear in place. The
existing "View Image" option displays the image in a separate browser window.
However this is probably a separate issue, namely bug 47475.

Tim.
I think Steve would be the one to do this...
Assignee: vishy → morse
Component: Browser-General → Cookies
QA Contact: doronr → tpreston
Looking for volunteers to do this.
Assignee: morse → nobody
Component: Cookies → ImageLib
Depends on: 75338
This is still a request so I am changing status whiteboard to [imglib]
Whiteboard: [imglib]
i feel the benefit of this item is outweighed by the effect of adding an extra
menu item in the image context menu.

i have posted the 2nd draft to the Context Menu Revision 2 document located:

http://mozilla.org/projects/ui/communicator/framework/contextmenus/cmrev2-2.html
Agreed.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WONTFIX
Agreement in UI people -> VERIFIED

(This could always be implemented as an XPI.)
Status: RESOLVED → VERIFIED
*** Bug 151636 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.