Closed Bug 1072346 Opened 6 years ago Closed 6 years ago

Unable to scroll #bottom-left-bottom completely when the browser window is short

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kats, Assigned: camd)

References

Details

(Keywords: regression)

Attachments

(1 file)

49 bytes, text/x-github-pull-request
jfrench
: review+
Details | Review
STR:
1. Load https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=093a487531cf
2. Click on the R14 failure
3. Resize your browser window to be short (say 400 pixels tall)

Expected results:
Can scroll the bottom-left pane (which starts off with "Result: testfailed") all the way to the bottom

Actual results:
Cannot do that. Actually I think what's happening is that there's some other container higher up in the DOM that has overflow:hidden but whose contents are overflowing. So even though you can scroll #bottom-left-bottom completely it's getting clipped by this other overflow:hidden thing it's contained in.
I can repro.
OS: Mac OS X → All
Priority: -- → P3
Hardware: x86 → All
I tried this (on Windows) with Firefox and Chrome using latest master pushed today to prod, and it seems I can scroll all the way to the bottom, up to and including what seems to be the last line:

artifact uploadeduploaded_files.json

However there was also a change introduced in today's deployment which has reduced the text size/style in that panel(bug 1073749) at least on Windows. But I'm curious if you can now scroll the entire contents?
Nope, I'm still unable to the scroll to the bottom on OS X (Aurora desktop build).
Ok, thanks Kartikaya for checking.
Duplicate of this bug: 1077876
Priority: P3 → P2
I tried again with latest production on Windows in case anything changed, but it still seems fine for me with both Firefox and Chrome so far. Perhaps we might want to update the bug Summary or the listed Platform value if/when we become more certain it is OSX specific.
FWIW I'm still seeing this on OS X in the latest aurora desktop build.
I can reproduce this on Linux x86-64. A simple way to do it is to open Responsive Design View in Firefox and use 1280x600.
Another prod push was performed today, this time with a grunt build prior, so the changes should appear properly. How is the behaviour now? :-)
Assignee: nobody → cdawson
Status: NEW → ASSIGNED
Seems to be fixed on the latest treeherder. Thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I believe this change pushed to prod causes the job panel to not launch, on Chrome. :camd is working on an overall improvement which will address that while preserving the fix in this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1088312
I checked in with camd in channel yesterday, he may try to push just the fix for Chrome, first.
Hi camd, any news on the job panel fix for Chrome?
Flags: needinfo?(cdawson)
Keywords: regression
Attached file PR268
Flags: needinfo?(cdawson)
Attachment #8521699 - Flags: review?(tojonmz)
jfrench: this is a ridiculously simple fix for chrome.  Thanks for not letting this fall through the cracks.  :)  You're a good man, Charlie Brown.
Commits pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/41e1db2a1ac7d880191fbfb5c85c09b6a171b9d6
bug 1072346 - make detail panel visible in chrome

https://github.com/mozilla/treeherder-ui/commit/f5f518543af676d3cc76315382c51fb6ea5867dc
Merge pull request #268 from mozilla/detail-panel-chrome

bug 1072346 - make detail panel visible in chrome
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 8521699 [details] [review]
PR268

Looks good, and it works properly in Chrome when tested on dev this evening.
Attachment #8521699 - Flags: review?(tojonmz) → review+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.