Fix RemoteAddonsParent.jsm console error spew with e10s

RESOLVED DUPLICATE of bug 1140629

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 1140629
3 years ago
2 years ago

People

(Reporter: jimm, Assigned: mauricioc, Mentored)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [good first bug][lang=js])

(Reporter)

Description

3 years ago
[JavaScript Error: "TypeError: value is not a non-null object" {file: "resource://gre/modules/RemoteAddonsParent.jsm" line: 776}]

[JavaScript Error: "event is undefined" {file: "resource://gre/modules/RemoteAddonsParent.jsm" line: 473}]

If you run in debug, there's at least one more common one.

Comment 1

3 years ago
Jimm: Want to mentor this?
Flags: needinfo?(jmathies)
(Reporter)

Comment 2

3 years ago
sure!
Mentor: jmathies@mozilla.com
Flags: needinfo?(jmathies)
Summary: Fix RemoteAddonsParent.jsm console error spew → Fix RemoteAddonsParent.jsm console error spew with e10s

Comment 3

3 years ago
Can you explain, what we exactly need to do in this bug? Thanks!!

Comment 4

3 years ago
Hi, Manu - Thanks for your interest. It looks like it's going to be a question of suppressing some error messages when we're running with Electrolysis enabled, but Jim can tell you a bit more about it. Jimm, can you give us some DXR links here?
Flags: needinfo?(jmathies)
(Reporter)

Comment 5

3 years ago
We have a module which acts as a addon shim when running in e10s mode - 

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/addoncompat/
 
It throws random errors at times when loading pages implying the code in this module doesn't handle unexpected condition well. So we need to take a look at this and try to clean it up.

You'll need a local debug nightly build for starters.  Manu Jain, have you gotten that far?
Flags: needinfo?(jmathies) → needinfo?(manu.jain13)

Comment 6

3 years ago
Jim, yes I have a local debug nightly build.Also I'm interested in patching this bug. Can you assign this to me? Thanks!!
Flags: needinfo?(manu.jain13)
(Reporter)

Updated

3 years ago
Assignee: nobody → manu.jain13
(Reporter)

Comment 7

3 years ago
Ok, in your test profile enable e10s through Options. Then run the debug build using that profile. You should see a few console errors from RemoteAddonsParent.jsm during startup and page load. The "event is undefined" is most common. What we want to do is find the code that generates that, figure out what it's supposed to be doing, and figure out why it errors out randomly during regular operation.

Updated

3 years ago
Status: NEW → ASSIGNED

Comment 8

3 years ago
My extension Extensor fails with e10s enabled due to a listener apparently not being defined on line 503:6 of RemoteAddonsParent.jsm:

  if (filteringListeners.has(listener)) {

Perhaps this issue could be addressed as well? 
Is there any change I could make to prevent this bug?
(Assignee)

Comment 9

2 years ago
Hi! I asked on IRC for a first e10s bug and this was suggested to me. I will work on this today. Let me know if there are any objections.
Assignee: manu.jain13 → mau
(Assignee)

Comment 10

2 years ago
I can't reproduce this bug on mozilla-inbound tip nor on a build from the day the bug was filed, even though I have AdBlock Plus and Firebug installed. Given the nature of the bug, the fact that RemoteAddonsParent.jsm didn't have 776 lines on 2014-09-24 and that RemoteAddonsParent.jsm:473 is seemingly dispatching an event coming from the addon [0], I'm going to assume this is a just JavaScript error in the addon that gets reported differently in e10s (i.e., this is a dupe of bug 1140629). Let me know if this is wrong.

[0] https://hg.mozilla.org/mozilla-central/file/1ab4be446c67/toolkit/components/addoncompat/RemoteAddonsParent.jsm#l473
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1140629
You need to log in before you can comment on or make changes to this bug.