Closed Bug 1072663 Opened 5 years ago Closed 5 years ago

Update removed-files for the move from Contents/MacOS to Contents/Resources

Categories

(SeaMonkey :: Installer, defect)

All
macOS
defect
Not set

Tracking

(seamonkey2.31+ fixed, seamonkey2.32+ fixed)

RESOLVED FIXED
seamonkey2.32
Tracking Status
seamonkey2.31 + fixed
seamonkey2.32 + fixed

People

(Reporter: rstrong, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

With Mac v2 signing we need to use the Contents/Resources directory and the removed-files.in file only understands the Contents/MacOS directory. To deal with this there are two new defines in packager.mk that point to the Contents/MacOS and the Contents/Resources directory on Mac and are empty for other platforms so it is simple to have one entry in the removed-files.in file that work for all platforms.

Note: the SeaMonkey removed-files.in file can be massively cleaned up similar to bug 649607 for Firefox but that shouldn't hold up getting this landed.
Attached patch patch (obsolete) — Splinter Review
Could you drive the review for these patches? We are shooting to land on Monday.
Attachment #8494873 - Flags: feedback?(bugspam.Callek)
Comment on attachment 8494873 [details] [diff] [review]
patch

Review of attachment 8494873 [details] [diff] [review]:
-----------------------------------------------------------------

Not clear to me where @DIR_*@ bits are coming from (when I'm looking at this patch in isolation).

f+ though, and if TB's patch(es) don't get a drastically different approach feel free to land. But I'm going to flag :jcranmer for official review assuming he's who will get the TB ones checked out as well.
Attachment #8494873 - Flags: review?(Pidgeot18)
Attachment #8494873 - Flags: feedback?(bugspam.Callek)
Attachment #8494873 - Flags: feedback+
It can be seen in the dependent bug - bug 1059567.

I doubt that I will have time to land this on c-c when all of the other bugs have landed on m-c.
Comment on attachment 8494873 [details] [diff] [review]
patch

I suspect Mark would be a better reviewer. I'll admit that I've not really paid much attention to the OS X stuff, so I can't comment in much detail about what needs to or doesn't need to be done.
Attachment #8494873 - Flags: review?(Pidgeot18) → review?(standard8)
Comment on attachment 8494873 [details] [diff] [review]
patch

Review of attachment 8494873 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=Standard. Thanks for the patch.
Attachment #8494873 - Flags: review?(standard8) → review+
I was able to compile comm-central by going to an earlier revision of mozilla-central. In doing so I found some replace errors and updated this file.
Attachment #8494873 - Attachment is obsolete: true
Attachment #8496717 - Attachment description: patch → patch. Carrying forward f=Callek r=Standard8
Attachment #8496717 - Flags: review+
Attachment #8496717 - Flags: feedback+
Keywords: checkin-needed
Pushed to comm-central:
https://hg.mozilla.org/comm-central/rev/0d54c78a3cfc
Thank you for the patch.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.32
Comment on attachment 8496717 [details] [diff] [review]
patch. Carrying forward f=Callek r=Standard8

Regression caused by (bug #): 1047584
User impact if declined: Problems installing on OSX Marvicks
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): low to none.
String changes made by this patch: None
Attachment #8496717 - Flags: approval-comm-aurora?
Note Bug 1047584 and all dependent bugs were Uplifted to aurora and are now on mozilla-beta so I'm going to land all four on comm-beta and/or release to make it to SeaMonkey 2.31
Comment on attachment 8496717 [details] [diff] [review]
patch. Carrying forward f=Callek r=Standard8

Missed the uplift to aurora. Landed on Beta instead.
Attachment #8496717 - Flags: approval-comm-aurora?
You need to log in before you can comment on or make changes to this bug.