[Wikipedia] Text invisible when scrolling through the area with horizontal scrolling

RESOLVED DUPLICATE of bug 1070993

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1070993
4 years ago
4 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8494890 [details]
logcat_20140924_ScrollIssue.txt

When the user scrolls down on the area with vertical and horizontal scrolling, parts of the text become invisible. 

Repro Steps:
1) Update a Flame device to BuildID: 20140924063013.
2) Download Wikipedia from the Marketplace app.
3) Open Wikipedia app.
4) Navigate to an article page containing a horizontal scrolling sections. (e.g. 'Seattle').
5) Scroll down the section with the horizontal scrolling.

Actual:
Parts of the text become invisible. 

Expected:
The section scrolls in any direction properly without blocking any section.

Note:
The issue does not reproduce when 'Async Pan/Zoom' is unchecked under the Developer menu.

Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140924000243
Gaia: 93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b
Gecko: d7e31ecd48af
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
 
Repro frequency: 100%
See attached: logcat, video
http://youtu.be/ZjETCLeyc34
(Reporter)

Comment 1

4 years ago
This issue also reproduces on Flame 2.2, Flame 2.1(512mb):

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140924013003
Gaia: ff6dbb006e4e60edba697639aa2a2a199b07069b
Gecko: 1e2993c99323
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KitKat Base (512mb)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140924000243
Gaia: 93a99bea0b40d81bd063f7d8b1964dc1ba35ba7b
Gecko: d7e31ecd48af
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Parts of the text become invisible while scrolling through the vertical + horizontal scrolling section.

========================================
This issue does NOT reproduce on Flame 2.0:

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140924003005
Gaia: 263e3b201dca967ec5346e35901aa981ca47dce7
Gecko: 35d791e16d31
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The text is displayed properly during scrolling, regardless the 'Async Pan/Zoom' setting.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]: regression
blocking-b2g: --- → 2.1?
Keywords: regression
This is fixed by the patch on bug 1070993, and is a regression from bug 1013385.
Blocks: 1013385
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070993
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.