'Don't show this message again' checkboxes don't work in Windows XP

VERIFIED DUPLICATE of bug 107264

Status

()

Core
Preferences: Backend
--
major
VERIFIED DUPLICATE of bug 107264
17 years ago
16 years ago

People

(Reporter: Tim, Assigned: Brian Nesse (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

On the two Windows XP machines I'm running at home, Mozilla fails to remember
when I check/uncheck a 'Don't show me this message again' checkbox e.g. when I
close the browser and it reminds me that Quick Launch is active, I choose for it
not to tell me again. It'll remember that until I reboot/turn off the machine,
and then it'll display it again  next time around. The same goes for 'encrypted
page' and 'unsecure connection' dialogs.

Reproducible: Always
Steps to Reproduce:
1. Choose to have Mozilla not show you a message again, e.g. the 'Quick Launch
is still active' dialog, on a Windows XP machine.
2. Re-boot or turn off the computer.
3. Start Mozilla again and the dialog will be back, regardless of the setting
you chose.

Actual Results:  Dialog boxes constantly reappeared

Expected Results:  Mozilla shouldn't have shown me the message again, after I
chose not to see it.

The same bug occurs in Netscape 6.1.

Updated

17 years ago
Severity: normal → major

Comment 1

17 years ago
-> QuickLaunch
Assignee: sgehani → law
Component: Preferences → QuickLaunch (AKA turbo mode)
QA Contact: sairuh → gbush

Comment 2

17 years ago
Questions:

Do you have multiple profiles?

Did you by any chance create your profile(s) when logged on as one WinXP user
and see the problem only when logged on as another user?

The only thing I can figure is that we are failing to write out the prefs.js
file (due to WinXP multi-user restrictions, is my guess).  Can you successfully
change other prefs (e.g., change your home page)?

Comment 3

17 years ago
I have the same behaviour at home : WinXP Pro FR / Mozilla 0.9.6
I only have one profile, and I always use the same Windows login (with Admin
rights). I can successfully change other preferences.
I can check what's in prefs.js if you like. Do you know by heart the line I have
to look for ?

Comment 4

17 years ago
I have the same Problem.
Running Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
on Win2k.
I only have one profile.
I have only seen this bug since 0.9.6.

Comment 5

17 years ago
Same problem here. Win98, both 0.9.7 and 2001122103 (and various nightly builds
from the past few weeks)

Just one profile.

Comment 6

17 years ago
By the way, this isn't a QuickLaunch problem; it shows up for all kinds of
preferences. The sort which pop up and have a "don't pop up again" option.

Someone with sufficient authority should change Component to, say, Preferences.

Comment 7

17 years ago
Okay, i have a workaround and some other information.

It appears to have been caused by something in my old prefs.js. Perhaps an older
version of Moz put something in there that a recent version was choking on.

Unfortunately, while trying to pinpoint the problem, i accidentally destroyed my
old prefs.js, the one that caused the problem. So i can't reproduce it anymore.

Can one of the other reporters please post their prefs.js as an attachment? 

Thanks.

Comment 8

17 years ago
Created attachment 62630 [details]
prefs.js that triggers the problem

Okay, i managed to pinpoint the problem and come up with some steps to
reproduce it:

Completely shut down mozilla.
Put the attached prefs.js in the appropriate directory
Launch mozilla.
Close it. You get the prompt.
Tell it never to come back.
Right-click the quicklaunch icon and select Exit Mozilla
Launch mozilla again.
Close it. You get the prompt.

Here's another really weird thing: There are two lines in the prefs.js. One is
commented out. However, if you actually delete the line that is commented out,
the problem goes away. So the javascript parser is not ignoring a commented-out
line like it's supposed to be.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
Resetting component to Preferences.  This doesn't seem to be QuickLaunch-
specific, according to the reporter.
Assignee: law → sgehani
Component: QuickLaunch (AKA turbo mode) → Preferences
QA Contact: gbush → sairuh

Comment 10

16 years ago
-> Prefernces: Backend for a look.
Assignee: sgehani → bnesse
Component: Preferences → Preferences: Backend
(Assignee)

Comment 11

16 years ago
prefs.js is a generated file, you should not be editing it. The JS parser is
throwing an error and ignoring the remainder of the file.

This is either invalid, or a dupe of bug 107264 (bad syntax in prefs.js causes
file to be ignored), I'm not sure which. Marking as dupe.

*** This bug has been marked as a duplicate of 107264 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.