Translation - Implement doorhanger for in-product promotion

VERIFIED FIXED in Firefox 34

Status

()

Firefox
Translation
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Felipe, Assigned: florian)

Tracking

unspecified
Firefox 35
Points:
5
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox32 wontfix, firefox33 wontfix, firefox34 verified, firefox35 verified)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8494985 [details]
translation doorhanger.png

We want to promote the translation feature for users to make it more likely to be found and understood.

Attached is the proposed mockup from Sevaan.
(Reporter)

Updated

3 years ago
Flags: firefox-backlog+
(Reporter)

Updated

3 years ago
Depends on: 1072743

Updated

3 years ago
Flags: qe-verify?
(Assignee)

Updated

3 years ago
Flags: qe-verify? → qe-verify+
QA Contact: bogdan.maris

Updated

3 years ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 5
(Assignee)

Comment 1

3 years ago
I see the doorhanger in your mockup has a "Learn more." link but what happens when it's clicked isn't specified. Should I just remove it?

Also, are the strings in this mockup placeholders or final strings?
Flags: needinfo?(sfranks)
Well, we should have some sort of content page somewhere about translation where a user can read a little more. I'm not sure of the process for getting this set up though.

Chad, can you point us in the right direction?

I am hesitant to remove it the learn more link just because we don't have a page yet.
Flags: needinfo?(sfranks) → needinfo?(cweiner)
(In reply to Florian Quèze [:florian] [:flo] from comment #1)

> Also, are the strings in this mockup placeholders or final strings?

The string is just a place holder. Matej, do you mind taking a look? We would like to draw attention to the translation bar through a promotional doorhanger that drops the first time the bar is displayed. Could you review the current string?

> Hey look! It's something new!
> 
> Now the web is even more accessible with Firefox's new 
> in-page translation feature. Click the translate button 
> to see it in action!
Flags: needinfo?(Mnovak)
Created attachment 8498883 [details]
Updated mockup of doorhanger

Comment 5

3 years ago
I like calling out something new so boldly. Another option would be to mention translation right in the headline. It could still be fun, something like "Instant translation. Instantly!"

Otherwise, here are a couple of small edits to the existing:

Hey look! It's something new!

Now the Web is even more accessible with our new in-page translation feature. Click the translate button to try it!
Flags: needinfo?(Mnovak)
(Assignee)

Comment 6

3 years ago
Created attachment 8499013 [details] [diff] [review]
WIP patch

Requesting feedback as this is mostly done.

What remains to do here:
- figure out how we are going to deal with the strings (but this can arguably be dealt with in bug 1072743).
- figure out what should happen when clicking the "Learn More" link (waiting for an answer from the needinfo flag Sevaan set on Chad).
- get a 64x64px rendering of the translation icon (Sevaan said on IRC "I bet mmaslaney can output whatever you need"), or decide we don't care if it's slightly blurry on retina Macs (tbh I don't think it matters much).
Attachment #8499013 - Flags: feedback?(felipc)
Flags: needinfo?(mmaslaney)
(Reporter)

Comment 7

3 years ago
Comment on attachment 8499013 [details] [diff] [review]
WIP patch

Review of attachment 8499013 [details] [diff] [review]:
-----------------------------------------------------------------

I tend to prefer not defining the pref and just setting it to true for the target profiles (i.e., "browser.translation.ui.welcomeMessageShown" or something like that)
Attachment #8499013 - Flags: feedback?(felipc) → feedback+
Thanks (In reply to Matej Novak [:matej] from comment #5)

Thanks Matej. After seeing it mocked up with the various headlines, I think the "Hey look! It's something new!" reads better.

Final strings:


> Hey look! It's something new!
> 
> Now the Web is even more accessible with our new in-page translation
> feature. Click the translate button to try it!
(Assignee)

Comment 9

3 years ago
Created attachment 8499665 [details] [diff] [review]
Patch v2

Thanks for the feedback on the WIP.

For the "Learn more." link I think we can add a SUMO link in a follow-up.
For the retina icon, I don't think it really matters.
Attachment #8499013 - Attachment is obsolete: true
Attachment #8499665 - Flags: review?(felipc)
(Reporter)

Comment 11

3 years ago
Comment on attachment 8499665 [details] [diff] [review]
Patch v2

Review of attachment 8499665 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/translation/translation-infobar.xml
@@ +231,5 @@
> +              };
> +
> +              let locale = Cc["@mozilla.org/chrome/chrome-registry;1"]
> +                             .getService(Ci.nsIXULChromeRegistry)
> +                             .getSelectedLocale("browser");

you could just use Translation.defaultTargetLanguage here, right?
Attachment #8499665 - Flags: review?(felipc) → review+
(Assignee)

Comment 12

3 years ago
(In reply to :Felipe Gomes from comment #11)

> > +              let locale = Cc["@mozilla.org/chrome/chrome-registry;1"]
> > +                             .getService(Ci.nsIXULChromeRegistry)
> > +                             .getSelectedLocale("browser");
> 
> you could just use Translation.defaultTargetLanguage here, right?

If we decide the difference between es-ES and es-AR is irrelevant, then yes. Otherwise, no.
(Assignee)

Comment 13

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/09e85c63110c

Let's use a follow-up to make the "Learn more." link point to an actual URL or hide it.
Flags: needinfo?(mmaslaney)
https://hg.mozilla.org/mozilla-central/rev/09e85c63110c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
(Assignee)

Updated

3 years ago
Depends on: 1079559
We tested on Windows 7 64-bit, Windows 8.1 64-bit Surface Pro 2, Mac OS X 10.9.5 and Ubuntu 14.04 32-bit using latest Nightly (buildID: 20141010030201) and can confirm that the string matches with the proposed final string from comment 8, doorhanger will close if the user interacts with the PC and if 'Thanks' button is clicked, 'Learn more' does nothing and the doorhanger appears only on the very first page that triggers the infobar;after this it will not trigger again even after a restart. Is this the intended behavior with the doorhanger?
Flags: needinfo?(florian)
(Reporter)

Updated

3 years ago
Blocks: 1081296
(Reporter)

Comment 16

3 years ago
Comment on attachment 8499665 [details] [diff] [review]
Patch v2

Approval Request Comment
[Feature/regressing bug #]: This implements a promotional doorhanger that is shown once for users part of the translation trial, in order to inform and bring attention to the feature. A screenshot can be seen at attachment 8499666 [details]
[User impact if declined]: No promotional doorhanger
[Describe test coverage new/current, TBPL]: Landend on m-c, manually tested
[Risks and why]: Limited to the translation feature
[String/UUID change made/needed]: This feature carries strings but they will be hardcoded for the 5 locales that are part of the experiment. They will land in bug 1072743.
Attachment #8499665 - Flags: approval-mozilla-aurora?
status-firefox32: --- → wontfix
status-firefox33: --- → wontfix
status-firefox34: --- → affected
status-firefox35: --- → fixed
Comment on attachment 8499665 [details] [diff] [review]
Patch v2

Aurora+

Felipe, as discussed, please handle the landing of this patch yourself before the uplift of 34 to beta on Monday.
Attachment #8499665 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 19

3 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #15)
> We tested on Windows 7 64-bit, Windows 8.1 64-bit Surface Pro 2, Mac OS X
> 10.9.5 and Ubuntu 14.04 32-bit using latest Nightly (buildID:
> 20141010030201) and can confirm that the string matches with the proposed
> final string from comment 8, doorhanger will close if the user interacts
> with the PC and if 'Thanks' button is clicked, 'Learn more' does nothing and
> the doorhanger appears only on the very first page that triggers the
> infobar;after this it will not trigger again even after a restart. Is this
> the intended behavior with the doorhanger?

This is the expected behavior. "Learn more" has been changed to do something in bug 1081296.
Flags: needinfo?(florian)
(Assignee)

Comment 20

3 years ago
(In reply to Sevaan Franks [:sevaan] from comment #2)
> Well, we should have some sort of content page somewhere about translation
> where a user can read a little more. I'm not sure of the process for getting
> this set up though.
> 
> Chad, can you point us in the right direction?
> 
> I am hesitant to remove it the learn more link just because we don't have a
> page yet.

Felipe and I figured it out with the SUMO people.
Flags: needinfo?(cweiner)
Great, thanks Florian. I also tested on the platforms from above using latest Aurora so marking this as verified fixed on both Nightly and Aurora.
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
You need to log in before you can comment on or make changes to this bug.