Closed Bug 1072764 Opened 6 years ago Closed 2 years ago

makeRemote ALL the targets

Categories

(DevTools :: Framework, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1397020

People

(Reporter: jryans, Unassigned)

References

Details

(Whiteboard: dt-fission)

We use remote targets all over the place now.  It no longer makes sense to sprinkle calls to |makeRemote()| all over the place.

Targets should be remote by default.
I'm adding code in bug 915448 that could be improved a bit once we fix this.
Product: Firefox → DevTools
Bug 1485676 is going to inline most of makeRemote into TargetFactory.forTab.
So it kind of fixes this bug, making most of makeRemote always called.
*But* the rest of makeRemote, dedicated to "attaching" things: attach the target actor and the console actors, is still being being done from too many places.

I'll try to remove all the unecessary callsites in bug 1397020.
Then bug 1492830 intends to clarify this attaching step and see if we can simplify that even more.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1397020
Whiteboard: dt-fission
You need to log in before you can comment on or make changes to this bug.