Sorting Messages selection not remembered between sessions

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Kent, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(9 attachments)

(Reporter)

Description

16 years ago
When starting mail/news is a often necessary to resort the messages in a mail
folder by date-decending.  This should be a selection remembered between sessions.

Comment 1

16 years ago
wfm - 2001101201

Updated

16 years ago
QA Contact: esther → laurel

Comment 2

16 years ago
I've also got this problem under WinMe from a few days back. Currently using
build  2001112603. As you move around the newsgroups, you often have to resort
the messages into Subject order. It seems that although the sort setting
(subject order) appears to be remembered, the headers are not sorted correctly
on loading that group.

Comment 3

16 years ago
Created attachment 62818 [details]
Sorting error

Messages set to display Unread.
Threaded is checked.
Happens when news/mail window is re-opened

Comment 4

16 years ago
Created attachment 62819 [details]
What it should be

This is the correct sorting, after I manually click the thread button on the
top left twice.
First time, it sorts in reverse order.

Note the circled thread

Comment 5

16 years ago
Created two attachments. This is a group that was sorted by subject,(and
correctly remembered its state between sessions). However, upon loading the
group, the list is not sorted correctly by subject.

From mailpic1.jpg, you can see that on entering the group, News has sorted it
incorectly (M,S,O,R,S)

However, after clicking on the "subject" header twice (once to sort reverse, and
then once again to sort normally) you can see that the sort order has changed
(ie  is now correctly sorted). This is shown in newspic2.jpg

Note that this seems to happen a lot with "Re:" messages. "Re: " should be
completey ignored and sorting should be done purely on the real subject line.

Comment 6

16 years ago
Created attachment 62823 [details]
Incorrectly sorted news postings on entering newsgroup

Comment 7

16 years ago
Created attachment 62824 [details]
Correctly sorted news postings after manually sorting twice

Comment 8

16 years ago
Any progress been made on this? I've just checked the latest nightly (2002020409
- afte the .9.8) and it still exhibits this bug as per the screen caps above.

Although it is not major, it doesn't instill confidence when trying to get
someone to move from other browsers to netscape/mozilla when mozilla can't even
sort a mailbox correctly!

Comment 9

16 years ago
Just checked build 2002021503, and its still failing to sort correctly. Can a
fix be scheduled or it at least be moved to "confirmed", rather than being left
into "unconfirmed" limbo for 4 months ?

Comment 10

16 years ago
this is a duplicate of bug 93655

Comment 11

16 years ago
Are you sure? The 93655 bug states that mail settings do not stick. 107280
States that mail settings do stick, but that sorting does not correctly take
place, eg, my settings are for subject order, but when entering the newsgroup
messages are sorted via subject order, but not correctly.

If this is a dupe (which they don't appaer to be), can this one be properly
duped to it instead of being left in unconfirmed limbo?

Comment 12

15 years ago
Since this bug was reported, a newer version of Mozilla (1.0 RC1) has been
released. Reporter, please can you check to see whether this bug is still 
present in a recent build (Moz1-RC1 or a new nightly build). If
this bug does not occur please can you resolve the bugreport?

Comment 13

15 years ago
I've been running RC1 since release, and the problem is still there. On
initially starting mail/news the problem can be a little hard to find (most of
what you see is sorted correctly), but there are always some incorrectly sorted
messages.

As you leave the mail/news window up and refresh your newsgroups periodically,
it becomes more and more likely that your newly shown messages will shown sorted
incorrectly.

I've attached two more pictures from RC1 that show the problem.

Comment 14

15 years ago
Created attachment 80554 [details]
Picture of newsgroup when entering for group initially

This is on intitially starting mail/news and selecting the newsgroup. Note that
the group has correctly remembered its "sort by subject" setting from the
previous session, but the sorting has not been done correctly on loading this
group.

Comment 15

15 years ago
Created attachment 80555 [details]
Picture of newsgroup messages after manually sorting

This is a picture of the same list after clicking the "sort by subject" widgit
twice. Once to reverse sort by subject, and then once again to get a forward
sort by subject. The initial click to get a reverse sort does correctly resort
the messages alphabetically, but in reverse order, so it seems that the sorting
mechanism itself does work correctly, but not when you initially select that
group to read and get the first listing of the group's messages in the listing
window.

Comment 16

15 years ago
Just checked Mozilla 1.0 RC-2. It's still showing the same faulty sorting
behaviour as described above.

Comment 17

15 years ago

*** This bug has been marked as a duplicate of 93655 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 18

15 years ago
#17 Please check comment #11 - this is not the same behaviour as 93655.

In this bug the sorted state is remembered correctly, but the sorting is not
done correctly. In 93655 the sorted state is not remembered correctly.

Note that this is still occuring in RC-3

Comment 19

15 years ago
Reopening by last comment and setting NEW.

pi
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 20

15 years ago
A bug so similar that I won't post a new report occurs to me for build 20021130
(that's the stable 1.2.1) on Win2k SP2:
I have set the sorting to subject ascending. It normally works very well, but
every now and then (every 4th or 5th time I download mail) it confuses the order
of the newly downloaded mails. The mails I download usually have the same
subject lines up to the 15th character or so.

Comment 21

14 years ago
I have a similar problem in the Search Messages window in e-mail on Mac OS X
(10.2.6) with Mozilla build 20030624, running on an Apple iBook (500MHz). Do I
need to enter this as a new bug, since this one (107280) is for Windows 2000?

Symptoms are: 
1) previous search done then sorted on date
2) do new search
3) Mozilla still highlights the Date column to show it as the sorting column,
yet the sorting isn't in any sequence of dates - neither ascending nor descending
4) sort on any other column then sort again by date ==> all is OK now... until
the next sort.

Regards, Stephane.

Comment 22

14 years ago
Created attachment 127956 [details]
View of Search Messages window after automatic sorting (or lack thereof), i.e. before manual re-sorting.

Updated

14 years ago
Attachment #127956 - Attachment description: View of Search Messages window after automatic sorting (or lack thereof) → View of Search Messages window after automatic sorting (or lack thereof), i.e. before manual re-sorting.

Comment 23

14 years ago
Created attachment 127957 [details]
View of Search Messages window after manual re-sorting

Comment 24

14 years ago
I'm no longer seeing this behaviour since the 1.4 release (maybe since 1.4 RC
2/3, but I didn't stick with those because of other problems).  Difficult for me
to do an apples to apples comparison as my OS has now been changed to WinXP.

Comment 25

14 years ago
Well, I too have Mozilla 1.4 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.4) Gecko/20030624). So, maybe the Mac version still has the problem.

Comment 26

14 years ago
Created attachment 135341 [details]
No patch

This bug still exist in 1.6a on Linux and is quite annoying because I never
sort messages by Date and never Ascending.

It could however be a wider problem with Mozilla saving preferred settings
because I have sometimes seen other settings lost, eg. passwords for
site-specific logins and where to put the included message that a reply is
written for, ie. I always want the new text on top, but sometimes have found
the setting to put the new text below.

Comment 27

14 years ago
I have same issue with TB 0.3 and 0.4a on Windows.
There should maybe be a setting to set default sort order which applies on new
accounts and would also apply if settings got lost.
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail
andrew, see you seethis?
QA Contact: laurel

Comment 29

10 years ago
yes, the original report is WFM
=> WFM per andrew
Status: NEW → RESOLVED
Last Resolved: 15 years ago9 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008060201 SeaMonkey/2.0a1pre

FWIW, this WFM too: I sort by Order Received but upwards in some folders and downwards in others, and Sm remembers it from one session to the next.

If you want to REOPEN, include specifics of how to reproduce, actual results, expected results, (which seem to vary between comments above) as well as your UA string (similar to the one at top of this comment, and found next to "Build Identifier" at bottom of the about: page).
You need to log in before you can comment on or make changes to this bug.