Last Comment Bug 1072815 - Multiple locales were missing in Lightning 3.3.1 release
: Multiple locales were missing in Lightning 3.3.1 release
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: x86_64 Windows 7
-- major (vote)
: 3.3.2
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on: 1049443
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-25 01:05 PDT by sheensam@gmail.com
Modified: 2014-12-27 11:56 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
lightning-win32-332.xpi (2.93 MB, application/x-xpinstall)
2014-12-24 04:07 PST, Philipp Kewisch [:Fallen]
no flags Details
lightning-win32-332.xpi - v2 (3.02 MB, application/x-xpinstall)
2014-12-24 17:44 PST, Philipp Kewisch [:Fallen]
no flags Details

Description User image sheensam@gmail.com 2014-09-25 01:05:06 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

My calendar(Lightning add-on) from 3.3 upgrade to 3.3.1. The Chinese UI is disappear.

I check lightning-zh-TW.jar,calendar-zh-TW.jar ,chrome.manifest can not found those jar files and zh-TW setting when I re-install Lightning plugin 3.3.1 version on MS windows.


Actual results:

 The 3.3.1 version not include calendar-zh-TW.jar, lightning-zh-TW.jar Chinese translation files.


Expected results:

It should be show up Traditional Chinese.
Comment 1 User image Peter Pin-Guang Chen [:petercpg] (MozTW.org) 2014-09-25 02:47:45 PDT
Confirmed. The 3.3 release on ftp.mozilla.org does have sk, zh-CN, zh-TW, but these locales are missing in 3.3.1 release on AMO, and Nightly locale builds are still working.

Pike, this should be something related to the building process right?
Comment 2 User image Axel Hecht [:Pike] 2014-09-25 03:18:47 PDT
I don't know a lot about calendar, moving over to there for investigation.
Comment 3 User image Philipp Kewisch [:Fallen] 2014-09-25 07:05:00 PDT
I wonder how this happened, I assume its because of the shipped-locales file on comm-esr31. Looks like I need to release 3.3.2.
Comment 4 User image Michael Bauer 2014-11-17 17:41:38 PST
Also reporting same for Lithuanian and Gaelic, seems to be a general problem
Comment 5 User image Philipp Kewisch [:Fallen] 2014-12-24 04:07:17 PST
Created attachment 8541232 [details]
lightning-win32-332.xpi

Could you try this xpi and see if it works for you? I've copied over all locales from 3.3
Comment 6 User image Michael Bauer 2014-12-24 04:15:59 PST
After restart, calendar is still all in English :(
Comment 7 User image Philipp Kewisch [:Fallen] 2014-12-24 05:14:17 PST
Michael, gd and lt were not part of Lightning 3.3 either, can you confirm? Is it possible that there was some mixup with the dashboard and signoffs at that time?
Comment 8 User image Michael Bauer 2014-12-24 05:26:25 PST
Isn't 3.3 well past the point when we agreed that signoff on Tb would automatically work for Lightning or something? I honestly can't remember, I'm useless with dates and numbers.
Comment 9 User image Philipp Kewisch [:Fallen] 2014-12-24 05:28:50 PST
Yes, at times of 3.3 the Thunderbird signoff is the one used for Lightning. I can't say why the locale was not included at that time though. The only way I can do that now is to manually compile calendar-gd.jar and lightning-gd.jar and add them in to 3.3.2. I can see if I can create a script that does it from the repository if you give me changesets that work.
Comment 10 User image Peter Pin-Guang Chen [:petercpg] (MozTW.org) 2014-12-24 05:50:44 PST
(In reply to Philipp Kewisch [:Fallen] from comment #5)
> Created attachment 8541232 [details]
> lightning-win32-332.xpi
> 
> Could you try this xpi and see if it works for you? I've copied over all
> locales from 3.3

zh-TW came back in this build.
Comment 11 User image Michael Bauer 2014-12-24 06:01:59 PST
I have no idea how to do a changeset but since the number of users is probably low for this locale, I'm ok waiting for 3.4 assuming it won't be a year or so before it comes out.
Comment 12 User image Philipp Kewisch [:Fallen] 2014-12-24 12:39:44 PST
With changeset I mean the version you would sign off on where the locale is green on the dashboard, but for the branch of 3.3.x. Version 3.4 is already in beta, thr next would be Lightning 4.0
Comment 13 User image Philipp Kewisch [:Fallen] 2014-12-24 14:18:27 PST
If you have trouble finding that version let me know, I'll try to extract the info from the dashboard and hg repository in the next few days.
Comment 14 User image Axel Hecht [:Pike] 2014-12-24 15:43:08 PST
I'd suggest to go through the tagged revisions on http://hg.mozilla.org/releases/l10n/mozilla-release/gd/tags (beta still tags, too)
Comment 15 User image Philipp Kewisch [:Fallen] 2014-12-24 17:44:20 PST
Created attachment 8541355 [details]
lightning-win32-332.xpi - v2

So I used the signed-off changeset from https://l10n.mozilla.org/shipping/l10n-changesets?av=tb31 for gd and lt, and both locales were missing strings at the time.

I also tried to go down a few commits in the gd repository, the closest I got to success was changeset 02974f2e1dbf from August 25th, where there are only 4 errors and no missing strings. The same for lt with changeset 3da4e0197337.

I've attached an xpi containing the locales at those changesets, please test.

The proposed release date for Lightning 4.0 is 2015-05-19 per https://wiki.mozilla.org/RapidRelease/Calendar (look for Firefox 38). We need to make sure we find a solution so this can be done with the build system until then. This means making sure the commits occur in the right order. If Thunderbird stuff was pushed first, you need to sign off Thunderbird on the Lightning changeset.
Comment 16 User image Michael Bauer 2014-12-26 06:16:27 PST
That worked for me (gd), thanks Philipp.
Comment 17 User image Rimas Kudelis 2014-12-26 12:22:52 PST
Seems to work for lt as well. Can you publish this update on AMO?
Comment 18 User image Philipp Kewisch [:Fallen] 2014-12-27 11:56:42 PST
Done, https://addons.mozilla.org/en-US/addon/lightning/versions/3.3.2

Note You need to log in before you can comment on or make changes to this bug.