Closed Bug 1072824 Opened 7 years ago Closed 2 years ago

Incorrect description in "MozillaWiki page X has been changed by Y" emails

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: spike)

Details

(Whiteboard: [messages])

The current wording is:
{
Dear Edmorley,

The MozillaWiki page MozillaWiki:Team has been changed on 24 September 2014
by Ckoehler, see https://wiki.mozilla.org/MozillaWiki:Team for the
current revision. 

See
https://wiki.mozilla.org/index.php?title=MozillaWiki:Team&diff=next&oldid=1017484
to view this change.

See
https://wiki.mozilla.org/index.php?title=MozillaWiki:Team&diff=0&oldid=1017484
for all changes since your last visit.

Editor's summary: add createbox for meeting agenda 

Contact the editor:
mail: https://wiki.mozilla.org/Special:EmailUser/Ckoehler
wiki: https://wiki.mozilla.org/User:Ckoehler

There will be no other notifications in case of further activity unless
you visit this page while logged in. You could also reset the
notification flags for all your watched pages on your watchlist.

Your friendly MozillaWiki notification system

--
To change your email notification settings, visit
https://wiki.mozilla.org/Special:Preferences

To change your watchlist settings, visit
https://wiki.mozilla.org/Special:EditWatchlist

To delete the page from your watchlist, visit
https://wiki.mozilla.org/index.php?title=MozillaWiki:Team&action=unwatch

Feedback and further assistance:
https://www.mediawiki.org/wiki/Special:MyLanguage/Help:Contents
}

However this is incorrect:
"See
https://wiki.mozilla.org/index.php?title=MozillaWiki:Team&diff=0&oldid=1017484
for all changes since your last visit."

Since that link is actually "...for all changes since this change."

ie: If I visit the page and then use that link again, I still get changes since 1017484, not changes since I last visited.

Ideally the verbosity of the whole email could be reduced - I find it takes me several seconds to pick out the change reason & also which link is the "all changes" rather than "just this change" (I prefer using the former).
I don't know if there is an easy way to apply wikimo specific customisations to:
https://github.com/wikimedia/mediawiki-core/blob/bb2d13313743d27f974a387693b5e739f341d6f7/languages/i18n/en.json#L1851

... or whether we'll need to sort this upstream.
(In reply to Ed Morley [:edmorley] from comment #1)
> I don't know if there is an easy way to apply wikimo specific customisations
> to:
> https://github.com/wikimedia/mediawiki-core/blob/
> bb2d13313743d27f974a387693b5e739f341d6f7/languages/i18n/en.json#L1851
> 
> ... or whether we'll need to sort this upstream.

As a matter of fact, we can!

https://wiki.mozilla.org/MediaWiki:Enotif_body
(In reply to Gordon P. Hemsley [:GPHemsley] from comment #2)
> (In reply to Ed Morley [:edmorley] from comment #1)
> As a matter of fact, we can!

The problem is, the actual text you're referring to is actually part of $PAGEINTRO and/or $NEWPAGE, so we'll have to track down where those values come from.
I'd argue that the message isn't really inaccurate since at the time the email (and the link) are generated, it's correct. But I can see how it would be confusing.

Suggested new wording:

"See $1 for all changes since your last visit (at the time this email generated)."

I can't think of a way to reduce the wording and be specific about the timing. Suggestions welcome, though.
Whiteboard: [messages]

Modified https://wiki.mozilla.org/MediaWiki:Enotif_lastvisited to read "See $1 for all changes since your last visit (at the time this email generated)."

Spike

Assignee: nobody → spike
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.