Closed Bug 1072848 Opened 5 years ago Closed 5 years ago

[Bluetooth][KK] Could not auto connect to BT headset after paired

Categories

(Firefox OS Graveyard :: Bluetooth, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.1+, firefox33 wontfix, firefox34 fixed, firefox35 fixed, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 fixed)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- fixed

People

(Reporter: ashiue, Assigned: shawnjohnjr)

References

Details

(Keywords: regression)

Attachments

(1 file)

Gaia-Rev        a7e53d661a1329d6813bc6104555b57dbb5e4d85
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/84d2b47c102d
Build-ID        20140924160202
Version         34.0a2

STR:
1. Find BT headset under "Devices in the area"
2. Tap to pair the device

Expect result:
connect to the BT headset without problem

Actual result:
After step 2, BT headset disapper from "Devices in the area".
Press "Search for devices" and press BT headset try to pair again, BT headset show on "Paired devices" but without auto connected.
[Blocking Requested - why for this release]:
Basic functional issue
blocking-b2g: --- → 2.1?
QA Whiteboard: [COM=Bluetooth]
I saw that problem too on 2.1 but not on 2.0 (both with the KK base image).

REPRO on 2.1:
Gaia-Rev        6a6ed9433fce47e76c07fd35bc5952acb108f4c8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/7b09a378588c
Build-ID        20140926000202
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140926.033610
FW-Date         Fri Sep 26 03:36:21 EDT 2014
Bootloader      L1TC10011800


NO repro on 2.0:
Gaia-Rev        ba0d4aef95a8a70c276966735aeb7bf82e5a5a0b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/d09b512223d4
Build-ID        20140926000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140925.032857
FW-Date         Thu Sep 25 03:29:07 EDT 2014
Bootloader      L1TC10011800

I guess this issue is not only a KitKat problem then. Let's find a regression window.
Assignee: nobody → shuang
Triage:regression, blocking.
blocking-b2g: 2.1? → 2.1+
Severity: normal → major
Add patch of bug 1065999, i cannot hit the same problem.
Depends on: 1065999
Let's wait for bug 1065999 patch land on v2.1.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065999
removing keywords - issue is resolved (dupe)
Verified on
Gaia-Rev        55ce3612bd8a8665139d6b85114ce59993a3fa0a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/8811060bf3fe
Build-ID        20141008160203
Version         34.0a2
Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Attached video video of verify issue
This issue can't repro on Flame 2.1
See attachment: verify_video.mp4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141118.035447
FW-Date         Tue Nov 18 03:54:58 EST 2014
Bootloader      L1TC00011880
You need to log in before you can comment on or make changes to this bug.