IMAP timeouts, HTTP ERROR 504 when accessing zimbra web UI

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: hlangi, Assigned: justdave)

Tracking

Details

(Reporter)

Description

3 years ago
Getting reports of people getting a HTTP ERROR 504 when trying to access https://mail.mozilla.com

abr & jgruen are both on the following server: zmmbox1.mail.corp.phx1.mozilla.com

I'm on zmmbox2 and don't have any issues.
Probably an issue contained to zmmbox1.  verified by graphs:

https://www.dropbox.com/s/wwc7qq3oglcxsmt/Screenshot%202014-09-25%2011.06.07.png?dl=0
david scravaglieri and john bernard are on zmmbox1.mail.corp.phx1.mozilla.com as well and experience the same 504 error
Don't know if it helps but it happened after reseting my LDAP password
Thanks David.  Shouldn't be related at all but never hurts to call it out.

Attempting to restart zimbra on zmmbox1 now.
David reports error 502 now with the Web UI
Nisha Malhan reports the same error (502) - she's on zmmbox1 too.
Restarted and working, though I don't want to call the all clear yet.
Assignee: server-ops → justdave

Updated

3 years ago
Duplicate of this bug: 1072964

Comment 9

3 years ago
I can now connect via both IMAP and webmail, however I am missing some bugmails that should have been delivered during the downtime. Are these just backed up in a queue?
Ed: more than likely.  If a mail delivery gets deferred it'll usually retry every 15 minutes to an hour afterwards, so if you don't have it within an hour I'd worry.

Based on the graphs, things appear to have initially gone sour around midnight, and went into a slow death spiral at that point.  Looking through the logs, we appear to have had a user using the Zimbra Outlook Connector about that time who appears to have triggered https://bugzilla.zimbra.com/show_bug.cgi?id=90726 (we've had tickets with Zimbra about this situation before).
Our two previous support cases on this issue were 00130451 and 00132019
Also pleased to report that within minutes of reporting to Zimbra that we got nailed by this again, the bug was moved to P1 priority and retargeted to the next upcoming minor release (it had been targeted to next major before).  They've definitely been getting on top of things much better since they separated from VMware.
I guess I should have resolved this with comment 10...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.