App statistics page is not loaded correctly

VERIFIED FIXED in 2014-09-30

Status

Marketplace
Consumer Pages
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Iulian Timis, Assigned: ngoke)

Tracking

2014-09-30
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [qa+])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8495309 [details]
app_statistics.png

Steps to reproduce:
1. Sign in MP-dev page
2. Load details page of an app with public statistics (https://marketplace-dev.allizom.org/app/chess-1 )
3. Click on “Statistics” button

Expected results:
Statistics page is loaded with no errors.

Actual results:
A white page with a gray section is displayed.

Notes/Issues:
Verified on FF35 (Win 7). Not reproducing on MP-stage and MP-prod.
Attaching screenshot for this issue.
Assignee: nobody → dspasovski
The issue here is we've started removing persona's include.js shim which gives us 'navigator.id'. Let's update 'marketplace-stats' so that we can login without it.
Assignee: dspasovski → nobody

Updated

4 years ago
Blocks: 1007956

Updated

4 years ago
Assignee: nobody → kngo
(Assignee)

Comment 2

4 years ago
The problem is marketplace-stats is on Commonplace 0.2.1 which is ancient.
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla/marketplace-stats/commit/4900d062e98259ec3dbbc9fda0a17e453c8b0c02
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [qa+]
(Reporter)

Comment 4

4 years ago
Verified as fixed in https://marketplace-dev.allizom.org/ on FF35 (Win 7).
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

4 years ago
Created attachment 8495824 [details]
postfix_statistics.png
You need to log in before you can comment on or make changes to this bug.