reqincs.inc hack in config.mak is failing

VERIFIED DUPLICATE of bug 103460

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 103460
16 years ago
13 years ago

People

(Reporter: Daniel (Leaf) Nunes, Assigned: Daniel (Leaf) Nunes)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
i'm not sure why, but the hack alecf put in for win98 systems isn't quite
creating the right reqincs.inc file:

D:\mozilla\string\obsolete>cat reqincs.inc
REQINCS=-I....distinclude\1 -I....distinclude\1

i'm working on a fix (unless, of course, the right fix is just to fix the
makefiles to use the right include macros in the first place, instead of running
perl for every makefile.win file to fix the incorrect includes; i'll take advice
for which is the right fix :)
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 1

16 years ago
cc'ing jon and chris, who have both taken a swing at this.

Comment 2

16 years ago
Try this in the Win95 section:

REQINCS1=REQINCS=-I $(XPDIST)/include/$(REQUIRES: = -I$(XPDIST^)/include/)

!if [echo.dummy $(REQINCS1) > reqincs.inc]
!endif

Make it say echo.dummy

It was working ok for me but I got tired of Win9X hanging if I tried to use IE 
and compile at the same time so I switched to 2K.
FrodoB tried the echo.dummy thing but it only expanded the first set of headers
or something like that.  I don't have a win98 with a build system so I'm kinda
shooting in the dark here.


*** This bug has been marked as a duplicate of 103460 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Both solutions worked for me on Win98

Comment 5

16 years ago
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.