If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Notification tray should close with a slide up gesture anywhere, not just the grippy

RESOLVED DUPLICATE of bug 1054239

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1054239
3 years ago
2 years ago

People

(Reporter: dietrich, Unassigned, Mentored)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=js])

(Reporter)

Description

3 years ago
>> Feature Request Title:
Notification tray should close with a slide up gesture anywhere, not just the grippy

>> Description of feature, or problem to be solved
Today, there is no way to close the notification tray other than to start your touch-and-slide on the grippy at the bottom of the screen. It's awkward to get your finger down there when holding the device in one hand.

I recommend that we close the notification tray when a swipe up gesture anywhere on the screen is detected.

When the notification tray is open, there's no ambiguity about the user intent with a swipe up gesture.

>> Impact of implementing the feature/solution
If this solution were to be implemented, it would save users from having to do awkward hand movements or to use both hands in order to close the notification tray.

>> Impact of NOT implementing the feature/solution
By not implementing this solution, the notification tray is awkward to close and requires both hands.

>> Date required
Rob, what are your thoughts here?
Flags: needinfo?(rmacdonald)
(Reporter)

Updated

3 years ago
Mentor: dietrich@mozilla.com
(Reporter)

Updated

3 years ago
Whiteboard: [lang=js]
Flagging Wilfred for review
Flags: needinfo?(wmathanaraj)
Hi Dietrich....

Thanks for your suggestion and ergonomically it makes sense. I do, though, foresee a couple of issues with this proposal. First, the list of notifications is scrollable, so I would envision a lot of users closing the tray unintentionally... which is also quite annoying. Second, and more importantly, apart from the notifications, the tray does not actually move. The handle actually reveals a stationary tray. So sliding the tray away would break this model. (The reason the tray doesn't move is because we wanted to reveal the most recent notifications first to allow users to peak without having to fully open the tray.)

So based on this, let's leave the tray as is until we re-examine it... likely in the 2.3 timeframe.

- Rob
Flags: needinfo?(rmacdonald)
(Reporter)

Comment 4

3 years ago
(In reply to Rob MacDonald [:robmac] from comment #3)
> First, the list of notifications is scrollable, so I would envision a lot of users closing the
> tray unintentionally... which is also quite annoying.

Oops, sorry for not being clearer with my proposal!

I mean for this to happen *only* when the swipe occurs on the background - an area where there are no notifications.

Given that constraint, it seems like it would be difficult to accidentally trigger this.

> Second, and more
> importantly, apart from the notifications, the tray does not actually move.
> The handle actually reveals a stationary tray. So sliding the tray away
> would break this model. (The reason the tray doesn't move is because we
> wanted to reveal the most recent notifications first to allow users to peak
> without having to fully open the tray.)

I'm aware that it doesn't slide. However, the interactions for open/peek/close are all sliding actions, so this gesture would be similar.

Proscriptive solutions aside, the root problem is that the single method of closing the notification area is awkward and uncomfortable for two reasons:

1. It's at the bottom-middle of the screen, which is terrible to reach when using the device with one hand.

2. The activation area (in that awkward-to-reach place) is very small.

> So based on this, let's leave the tray as is
> until we re-examine it... likely in the 2.3 timeframe.

Great. Is that examination going to happen somewhere that people can participate?
Flags: needinfo?(wmathanaraj)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1054239
You need to log in before you can comment on or make changes to this bug.