Closed Bug 1073176 Opened 8 years ago Closed 8 years ago

[Dialer][Browser] When user receieves a call while watching a video on the web, the top portion of the call screen will blacked out

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: SalvadorR, Assigned: alive)

References

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-2], )

Attachments

(3 files)

Attached image blackout.png
Description:
When user plays a video player with the browser app, and watches a video in fullscreen, if user receives a call, the top portion of the entire screen will be blacked out, blocking the taskbar and caller's information.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140925000204
2) Play a Youtube video from the browser app
3) View the video in fullscreen and receive a call from another device
4) Observe the Callscreen
  
Actual: The entire top portion of the screen will be blacked out

Expected: 
The call screen shows properly when receiving a call
  
Environmental Variables:
Device: Flame 2.1(319mb)
BuildID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: This issue reproed on the following web video players: Youtube, Vimeo and Yahoo
  
Repro frequency: 5/5
See attached: Screenshot, Logcat
This issue also occurs on Flame 2.2

Actual: The entire top portion of the screen will be blacked out

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
----------------------------------------------------------------------
This issue does NOT occur on Flame 2.0

Expected: 
The call screen shows properly when receiving a call

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:Prevents the user from knowing who is calling them.
blocking-b2g: --- → 2.1?
I'm guessing this is a regression from bug 927862 but that's just a guess.
Component: Gaia::Dialer → Gaia::System::Window Mgmt
QA Whiteboard: [QAnalyst-Triage?]
Unable to provide Regression Window. 

Issue DOES occur in the earliest 2.2 Flame build (v180 base image).  

Device: Flame Master
Build ID: 20140904171737
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 8703c1895505
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Contact: ddixon
Duane - let's see if this repros in JB and we can find a window there with are larger collection of builds
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Flags: needinfo?(dharris)
B2G Inbound Regression Window

Last Working

Device: Flame 2.1
Build ID: 20140828211200
Gaia: 8d965e7182500fd1849e8eec5ae2aca35a55af22
Gecko: efb4f3f291a4
Version: 34.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken

Device: Flame 2.1
Build ID: 20140828223200
Gaia: 6f270b9fee0c1f09863f5e1aa640937a07c7fdae
Gecko: 18ed4643a705
Version: 34.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last Working Gaia and First Broken Gecko
Issue DOES NOT occur here. 
Gaia: 8d965e7182500fd1849e8eec5ae2aca35a55af22
Gecko: 18ed4643a705

Last Working Gecko and First Broken Gaia
Issue DOES occur here. 
Gaia: 6f270b9fee0c1f09863f5e1aa640937a07c7fdae
Gecko: efb4f3f291a4

Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/c0fa9fe2f91ea76191d4e7c58db1dbf2993f76c8...6f270b9fee0c1f09863f5e1aa640937a07c7fdae

Possible Cause: 
Bug 927862 - Implement AttentionWindow
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by Bug 927862 ? Can you take a look Alive?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
Attached file Patch for master
Cancel fullscreen when opening attention as previously did.
Attachment #8499378 - Flags: review?(etienne)
Triage: regression, blocking
blocking-b2g: 2.1? → 2.1+
Attachment #8499378 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/0d1889cc720af5266bc875febb38b09a2ad6f600
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8499378 [details] [review]
Patch for master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 927862 regression
[User impact] if declined: user is not able to see who is calling while there is a fullscreen element
[Testing completed]: green on tbpl
[Risk to taking this patch] (and alternatives if risky): simple/riskless
[String changes made]: no
Attachment #8499378 - Flags: approval-gaia-v2.1?
Attachment #8499378 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
BTW, why did this commit land under bug 1073216? Please be more careful in the future?
Flags: needinfo?(alive)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #14)
> BTW, why did this commit land under bug 1073216? Please be more careful in
> the future?

Oh my fault, sorry!
Flags: needinfo?(alive)
VERIFIED FIXED on v2.2.

Results: The call screen shows properly when receiving a call.

Environmental variables:

Device: Flame 2.2 Master
BuildID: 20141011040204 (full flash)
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

-----------------------------------------------------------------------

This issue STILL OCCURS on v2.1, slightly different from original report.

Results: The call screen appears properly, but the user is taken back to the homescreen instead of the video with entire top portion of the screen appearing white after the call dismisses. The video url will still be seen at the top of the screen, and the user is able to interact with the homescreen behind the white overlap. Restarting is required to resolve the issue.
*Screenshot attached.

Device: Flame 2.1 KK (319 MB) 
BuildID: 20141011000201 (full flash)
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2], [failed-verification]
New bug 1081565 created for the continued issue on v2.1
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+][failed-verification]
Depends on: 1081565
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory-2], [failed-verification] → [2.1-exploratory-2],
This issue is verified fixed on Flame 2.1. 

Call screen appears without any issues, and returns to the correct youtube video after the call has ended or is dismissed.

Flame 2.1 

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141017001201
Gaia: 1ea74943cfe525c76a074ca1d7de8e51a70f6b98
Gecko: 2befa902ff5c
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.