[Rocket bar browser] on a audio streaming site, when receiving a call wile streaming, causes performance issues

RESOLVED WORKSFORME

Status

Firefox OS
Performance
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-2] [systemsfe], URL)

Attachments

(1 attachment)

64.74 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8495579 [details]
log cat

Description:
on a audio streaming site (band camp used  for bug) a receiving a call wile streaming causes performance issues  


Repro Steps:
1) Update a Flame to 20140925000204
2) Go to band camp app in music
3) Select a song and start streaming it
4) Receive a call


Actual:
sluggish page reload with white screen


Expected:
immediate return to web page 

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140925000204
Gaia: 8061ab487d42cbc49b329fd68b9ca90e0fe477e6
Gecko: e970bc96f8b5
Version: 34.0a2 (2.1 319MB)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: logcat, video clip : http://youtu.be/YlNdy1HVjG8
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.2 (319mb) kitkat  2.0 (319mb) kitkat


on a audio streaming site a receiving a call wile streaming causes performance issues 

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140925040206
Gaia: c5d2e2f4ebf5f370d6003517057dcd47493dec90
Gecko: 32acbe1d64dc
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140924183011
Gaia: 87ee41fcb3f9a14d7a8bb67f1dd7fd95a6bcd0f0
Gecko: b1cb27078909
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Updated

3 years ago
Whiteboard: [2.1-exploratory-2] → [2.1-exploratory-2] [systemsfe]
This seems like it might be a dupe of bug 1072602. NI performance owner. Can you weigh in on this geo?
Flags: needinfo?(gmealer)
Mentioned in the other bug, but I don't own performance--I've been doing work around QA release acceptance and stats analysis, but ownership is by individual functional teams.

That said, I wouldn't dupe this. Looks like totally different context, even if it ultimately ends up being same root cause.
Flags: needinfo?(gmealer)
Receiving a call while in browser and the phone is in landscape seems like a high use case. NI Dialer owner to see if this issue should block.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(jlorenzo)
This looks like the problem concerns the browser, which becomes white once the dialer is closed. As I'm not in the US, I couldn't use the e.me app of Bandcamp, I used the browser. I saw the white screen but the music started where I left.

This seems pretty minor to me. What do you think Marcia?
Flags: needinfo?(jlorenzo) → needinfo?(mozillamarcia.knous)
Is this only happening with band camp or with other streaming sites as well?

Comment 4 mentions being in landscape mode - is this only happening in landscape or portrait mode as well?

I don't agree this is a high use case in all markets - in some it may be, in other depending on streaming bandwidth it might.
Flags: needinfo?(mozillamarcia.knous)
I tested this using Grooveshark with the latest 2.1 and I was unable to reproduce the issue.

Comment 8

2 years ago
Per comment 7, close as worksforme.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.